Wireless & LAN interconnection



  • Hi All,

    I've just recently add a wireless segment on my network following the forum posts and it went well :D, but I have one query regarding the interconnection between these interfaces. I have a Freenas server located on the LAN interface, I want the user on the wireless interface to have access to this server, so I went to setup firewall rule on the OPT1 interface to pass all traffic from this network to the IP address of the Freenas server (Single host only rule). I also did the same on the LAN interface.

    Now, I can try to login to the Freenas server from any host on under OPT1 only to be greeted with the username and password (I set the freenas this way) but never been through at all. I tried to login from the hosts under LAN interface with the same username and password and it worked.

    So my question is, did I miss anything on the setup? I was able to ping the hosts back and forth but it seems that the connection from OPT1 hosts always get refused. Thank you in advance !!!



  • Anyone???


  • LAYER 8 Moderator

    Can you post further details like screens of that particular rule?
    Any chance you forbid connection with a rule above that one?
    How are Wireless Clients connected? Is the OPT1 IF bridged? Own IP Segment?



  • Hi,

    I was trying to get a screen shot last night but couldn't do it properly, as I'm at work today I'll try to describe the firewall rule as best as I can. Basically the rule that I setup is to allow network segment on OPT1 interface (172.30.X.X) to get access to the Freenas box (192.168.10.250) by specifying the source as the network segment and the destination as the single IP (Freenas IP) from the firewall rule at OPT 1 interface.

    I did a little bit of checking last night, and was able to ping the freenas server from a host under OPT1 interface (Laptop1). I even managed to login to Freenas web configuration by using http://freenas from the host in OPT1. But still unable to access the share from within the laptop under OPT1 interface.

    Connection diagram is as follow

    Internet -> ADSL Modem ->  <wan>-> Pfsense Box -> <opt1>-> Wireless AP -> OPT1 Subnet (172.30.0.0) -> Laptop1
                                                            |                                                                                  -> Laptop2
                                                          <lan>|
                                                      100Mb Switch
                                                            |
                                                LAN SUbnet (192.168.10.0)
                                                    |        |          |
                                                Freenas  PC1      PC2

    I hope the information is enough to help resolve this issue, thank you again for your help!!!</lan></opt1></wan>


  • LAYER 8 Moderator

    If you can't make a screenshot, just copy&paste the rule from the table view.
    Did you check if you have a rule above that forbids anything? The fact that you can connect and ping would lead me to the thought that something is wrong with netbios broadcasts. Can you access the share via UNC notation such as

    net use x: \\192.168.10.<ip>\<sharename></sharename></ip>
    

    Did you check the "System Logs" / "Rules" if there are blocked packages on WAN/OPT1 for the connection between the Laptops and the Freenas device?

    Greets Grey



  • Hi again Grey,

    I will not say this too loud  :-[, but the problem actually related with zone alarm personal firewall. As it by default only allowing traffic from the local subnet. So I added the "foreign" subnet on the firewall, and it worked like a charm !!.. Oh well sometimes the simplest problem can always be forgotten.. :D

    Anyway, thanks a lot for the help. I hope that this post can be a reference for future use.


  • LAYER 8 Moderator

    Don't mention ;) I, too, had some of that enlightenments ;D


Log in to reply