System/Firmware update broken.



  • snapshot from the 11th of Feb….
    pfSense System Update page shows no information at all, does not show installed version and gives no manual way to update even though it has full internet access (it's routing for the PC making this post).


    How the Heck are you supposed to upgrade this now? Changing the only one setting available on the update settings tab from Development to Stable or vice versa makes no difference.
    Where has the manual update feature gone??



  • Login via ssh and use option 13



  • When using update option 13 from console as suggested:

    Updating repositories metadata…
    Updating pfSense-core repository catalogue...   
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    return: Illegal number: -1
    Your packages are up to date.
    Welcome to pfSense 2.3-Beta-pfSense (amd64) …............

    on reboot shows:
    pkg: No package(s) matching pfSense-Kernel-*
    pfSense (pfSense) 2.3-Beta amd64 Thu Feb 11 18:34:21 CST 2016
    Bootup complete

    It goes through the paces and essentially does nothing, same version installed after reboot, seems its more than a simple GUI error.
    Trying to think of what would be different on this machine than any others.. Dell r300 1U rack mount server with Perc 6I raid controller,  ran 2.2.6 just fine, no packages were installed or in use. She was updated to 2.3 and now this.

    firmware_update_misc_log.txt



  • What happens if you choose option 12 and type in:
    playback gitsync master

    Does it sync and then if you visit update page it shows correct values?



  • @foonus:

    snapshot from the 11th of Feb….
    pfSense System Update page shows no information at all, does not show installed version and gives no manual way to update even though it has full internet access (it's routing for the PC making this post).


    How the Heck are you supposed to upgrade this now? Changing the only one setting available on the update settings tab from Development to Stable or vice versa makes no difference.
    Where has the manual update feature gone??

    Happens to me when i enable Ram disks. Try disable it first, update and tour it back on.



  • Well, I did a Clean install of today's latest.  The Updates do show correctly on the dashboard now as well as the System Update tab. However I can confirm that if "Use RAM Disks" is Checked, both dashboard and update tab are completely broken. This was not the case in the original Update from 2.2.6, as checking or unchecking the option after that still left the Updates broken!



  • I'm having the same problem.  Was playing around and enabled the RAM disks, then lost the ability to get updates.  Packages still install, but seems that just the system update is broken.  I've disabled RAM disks, but still no luck getting updates.  Tried the "playback gitsync master" from the console suggestion.  It sync'd, but still no luck getting the system update to work.  Appreciate if anyone has suggestions.  Would rather not have to reload.



  • I piddled around with this a bit more.  My only guess is at some point when I turned on RAM disks, the /var/db/pkg database became corrupted some how.  I traced the functions that are used to determine if an upgrade is needed and found that the call to "pkg info -e pfSense-base-pfSense" never returns a value (the function also calls "info -e pfSense-base" and "info -e pfSense", all of which return nothing).  I think at this point the only resolution is a reinstall.

    Here's the snippet of code from pkg-utils.inc that is returning false, which then it generates the message "Unable to check for updates":


    $base_pkg = get_base_pkg_name();
    $meta_pkg = get_meta_pkg_name();

    if (!$base_pkg || !$meta_pkg) {
    return false;
    }
    ...


  • Administrator

    Can you please run the following command on shell and let me know results?

    pkg info 'pfSense-*'



  • I have got the same problems. Also started after enabling ramdisks. Disabling them does not help.

    results from pkg info 'pfSense-* are:
    pfSense-pkg-Service_Watchdog-1.8.2_1
    pfSense-pkg-openvpn-client-export-1.3.6_1
    pfSense-pkg-pfBlockerNG-2.0.7
    pfSense-pkg-snort-3.2.9.1_6
    pfSense-pkg-squid-0.4.15
    pfSense-repo-2.3.b.20160304.0222

    Thanks in advance