2.3 Slow download, good upload



  • Hi,
    i've installed the new version 2.2.6 to my boxes.
    But now my openVPN-DL-Speed is terribly slow.

    The upload-speed is okay. (see the first attachement)
    in theory it should be a 50/10 Mbit-Line. So getting 8.85Mbit in upload is okay.
    But receiving only 0.5Mbit is really strange.

    what i have done:
    disabled tso: https://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards#TSO.2FLRO
    checked the box for  "Disable hardware checksum offload"
    tried a DL directly on the box (see 2nd attachement)  - There i get 10MBps - so nearly a full 100Mbit - which is okay.
    messing around with TLS, cyphers, etc. in the openvpn-server config.

    pfsense is virtualized within a KVM
    using a fresh install
    only installed tool: openvpn export utility
    CPU-Load will go up to ~8% at sending the 9Mbit.
    CPU-Load will stay at nearly 0% while downloading (since it's freaking slow)

    on older versions there wasn't that much of a problem. I still got some errors, but the speed was around 40Mbits (for my connection)

    Any idea what I could have missed?
    Thanks!

    edit forgot to mention:
    this happens on multiple PCs, Macs (and even another pfsense, i connected to this one)
    also it's probably not a problem of the connection itself, i've tested it on two different locations (though the same ISP)

    Also no errors on the client or server-side in either logs :/

    i've also moved the pfsense to vultr and try their connection - same problem.

    the only thing that works nice, is Site-to-site-connection :/
    ![Bildschirmfoto 2016-02-14 um 14.51.10.png](/public/imported_attachments/1/Bildschirmfoto 2016-02-14 um 14.51.10.png)
    ![Bildschirmfoto 2016-02-14 um 14.51.10.png_thumb](/public/imported_attachments/1/Bildschirmfoto 2016-02-14 um 14.51.10.png_thumb)
    ![Bildschirmfoto 2016-02-14 um 14.53.37.png](/public/imported_attachments/1/Bildschirmfoto 2016-02-14 um 14.53.37.png)
    ![Bildschirmfoto 2016-02-14 um 14.53.37.png_thumb](/public/imported_attachments/1/Bildschirmfoto 2016-02-14 um 14.53.37.png_thumb)



  • I don't have a solution for you but I did want to let you know that I show the same :( I'm running 2.2.6. The OpenVPN pfSense box is at a site with 100mbit/s down and 20mbit/s up. When pulling files FROM this site TO a remote client, I would expect 20mbit/s minus some overhead. Instead? I'm getting 1.5mbit/s-2mbit/s. It's… quite frustrating.

    I'm seeing the same on a Windows desktop and a Mac laptop.



  • Updated to Version 2.3-RELEASE
    Still the same error trying to connect to the openvpn-Server…

    If i install a debian on the same hardware, the vpn will nearly max out my connection. on freebsd it's still very slow.
    Seems like i still can't use it.

    Any more help?


Log in to reply