Problema con instalacion pfsense (SOLUCIONADO)



  • Hola amigos,

    Tengo el error "run_interrupt_driven_hooks  waiting for xpt_config" al tratar de instalar el pfsense en un server. he intentado varias cosas y aun persiste el error. Les dare la informacion y lo que he realizado:

    Equipo: Servidor HP proliant ML350 G5
    Version PFsense 2.2.6

    Estoy tratando de instalar el pfense por primera vez, por lo tanto es una instalacion limpia nada de upgrade. Baje el archivo para arquitecturas 64bits para bootear por usb, luego de empezar la instalacion en el proceso aparece el error "run_interrupt_driven_hooks  waiting for xpt_config".

    Leyendo varios post y recomendaciones, ademas de la seccion de troubleshooting de pfsense casi todos recomiendan desabilitar puerto firewire (1394), deshabilitar usb, floppy, serial, etc. Lo deshabilite todo incluso el puerto iLO, menos el firewire que mi servidor no lo tiene, esto me obligo a bajarme nuevamente el pfsense arquitectura 64bits pero para ser instalado con livecd, el server empieza isntalacion y queda en el mismo punto con el mismo error y todas las soluciones apuntan hacia el mismo sitio.

    Espero me puedan ayudar.



  • Hola.

    Lo que dicen en https://doc.pfsense.org/index.php/Boot_Troubleshooting#Conflicting_Hardware

    If the system hangs right after detecting the hard drives, and the floppy drive light is on, turn off floppy support in the BIOS.

    If the system stops with an error such as:

    run_interrupt_driven_hooks: still waiting after 60 seconds for xpt_action

    Disable any Firewire/1394 controllers and USB Card Readers in the BIOS.

    Es que desactives o deshabilites en el Setup de la BIOS de tu servidor, floppy, firewire/1394, y usb card readers. A lo mejor ya lo has hecho, pero como no he leido BIOS en tu post …

    Busca también en foros de FreeBSD 10.1 (pfSense se basa en esa distro)

    Salu2



  • Gracias por responder amigo,

    Efectivamente ya habia realizado el procedimiento de deshabilitar puertos en la BIOS mucho antes de publicar esto en el foro sigue sin funcionarme, sin embargo, voy a buscar en los foros de Free BSD 10.1 como me comentaste, ya que es un problema de incopatibilidad del OS.

    De tener alguna respuesta la posteare aqui.



  • Nuevamente estoy aqui en el foro, pero con buenas noticias ya logre instalar el pfsense en mi proliant  8).

    La solucion fue bastante tediosa porque fue deshabilitando y cambiando valores en la BIOS hasta que funciono.

    Aqui la configuracion que realice para que me funcionara:

    • Puertos USB deshabilitados.
    • Puerto Serial deshabilitados.
    • Puerto paralelo deshabilitado.
    • Integrated lights-out deshabilitado. (Tambien llamado puerto ILo).
    • Floppy deshabilitado.
    • Puertos SCSI integrados son 2 exactamente (u320 HBA Port1 y u320 HBA Port2).

    Utilice la ultima version de pfsense hasta el momento 2.2.6 arquitectura 64 bits.

    NOTA: Los puertos SCSI integrados no los tenia en uso ya que todos los discos duros estan conectados en la controladora RAID PCI.

    Espero sea de ayuda para muchos aqui en la comunidad.  ;)



  • :)

    Enhorabuena.

    Salu2