Pfsense 2.2.6 captiveportal+squid3(transparent) ve check_ip.php sorun çözümü



  • Arkadaşlar Merhaba,

    pfSense üzerinden squid'i transparent olarak captive portal özelliği ile kullanıyorsanız bu özellik bug nedeni ile kullanılamıyor. Bu özellik benim için olmazsa olmazlardan çünkü squid(transparent)+freeradius2+captive portal+active directory+squiduard ile birlikte kullanarak internet erişimlerini kullanıcı adına göre sağlayıp raporlamaları ve yetkilendirmeleri kullanıcı adlarına göre yapıyorum. Büyük ağlarda çok faydalı ve güzel bir çözüm sağlıyor. Aslında sorun basit path hataları. Bunu çözmek için aşağıdaki adımları takip ederseniz bu özelliği tekrar kullanabilirsiniz.

    1. Öncelikle sembolik link olarak mevcut bulunan check_ip.php siliyoruz
    rm /usr/pbi/squid-amd64/bin/check_ip.php

    2. Ekte bulunan check_ip.php.txt dosyasını check_ip.php olarak değiştirip winscp gibi bir programla pfsense'in /root dizinine aktarıyoruz. Aşağıdaki komut ile dosyayı ilgili yere taşıyoruz
    mv /root/check_ip.php /usr/pbi/squid-amd64/bin/

    Daha sonra path hataları sonucu bulunamayan dosyaları sembolik link olarak tanımlıyoruz.

    ln -s /usr/local/bin/php /usr/pbi/squid-amd64/local/bin/php
    ln -s /usr/local/lib/php /usr/pbi/squid-amd64/local/lib/php
    ln -s /usr/local/etc/php.ini /usr/pbi/squid-amd64/local/etc/php.ini
    ln -s /usr/local/lib/libsqlite3.so.0 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libcurl.so.4 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libintl.so.8 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libldap-2.4.so.2 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libmcrypt.so.4 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libonig.so.1 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libzmq.so.5 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libssh2.so.1 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/ipsec/libvici.so.0 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/liblber-2.4.so.2 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libltdl.so.7 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libsodium.so.13 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libpgm-5.2.so.0 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/ipsec/libstrongswan.so.0 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libvstr-1.0.so.0 /usr/pbi/squid-amd64/local/lib/

    Hepsi bu kadar, bu özelliği tekrar kullabilirsiniz.

    Not: 2'nci maddede yapılan işlem sırasında örneğin libcurl.so.4 gibi mevcuttur gibi mesajlar alabilirsiniz, her versiyonda farklı farklı link problemleri olduğı için yenilemedim. mevcut olanlar için uyarı veriyor sadece.

    Kolay gelsin.
    check_ip.php.txt



  • Dikkat bu işlemi yapmadan önce mutlaka sistem yedeklerinizi alınız.

    Deneyenler geri dönüş yapsın lütfen ona göre başlığı sabitleyelim.


Log in to reply