Redirection apres le logging



  • Bonjour à tous,

    voici ma configuration de test (pour l'instant)

    j'utilise pfsense pour son portail captif.

    l'authentification se fait sur openldap via freeradius ce qui fonctionne tres bien.(apres quelques temps passé dessus)

    j'utilise deux carte wan et lan.

    interface wan sur mon réseau interne dans un vlan séparé qui est routé (tout ca nickel)

    mon interface lan ou sont connecté mes bornes et mon réseau filaire sur un vlan spécifique.

    J'ai un petit souci apres mon authentification car mon navigateur ne me redirige pas.

    Je suis obligé de redemare mon navigateur pour pouvoir surfer.

    Cordialement,

    Julien Grenoble



  • Pas de redirection vers le site initialement demandé ?



  • oui tout a fait

    sachant aussi que avec les pages web interne a l'entreprise on a pas le probleme.

    et sinon au niveau config j'ai oublié de préciser que l on passait par un proxy pour sortir qui est squid.

    Merci d'avance pour toute vos réponse

    JuL



  • Rien dans les logs du firewall au moment de la redirection ? ET au  niveau du squid, que donne le access.log ?



  • désolé aucune info dans les logs de pfsense

    et du coté du squid de l'entreprise, pas la trace d'une requête.

    pas plus de news pour le moment.



  • Avee vous essayé une ptite capture Wireshark sur le poste client quand il se connecte, hhistoire de  voir les échanges entre pfsense et le navigateur client.



  • tout a fait
    enfin j ai mi un poste sur le switch sur un port monitoring sur lequel une image de tout le trafic qui transit par le switch est envoyé
    et donc la phase d'authentification se passe bien et le client fait des requetes http sans reponse et jai aucune trace de ces requetes sur mon squid donc je ne sais pas trop ou es que elles partent ???

    merci pour ton aide



  • aparament j'ai trouvé mon souci

    cela viendrai du serveur proxy de l'entreprise

    le navigateur a des souci pour l'atteindre avant d'être authentifier puis ne cherche pas a l'atteindre de nouveau apres l'authentification

    si quelqu un a une solution avec un serveur proxy éventuellement

    merci d'avance



  • Dans ce cas, c'est le client le fautif. Enfin, expliqué comme vous l'avez fait c'est le client qui refuse de retenter une connexion vers le proxy.



  • oui aparament c'est ce que j'en ai deduit aussi mais es que il y aurait pas une solution a se probleme

    merci encore


Log in to reply