Captive portal no squid não funciona



  • Sou novato e baixei recentemente o PFsense para implementar na minha empresa, aque não posso colocar com dhcp server então tenho que colocar por proxy, mas quando fui configurar o squid o captive portal não deixa ser ativado a caixinha para ser habilitado não aparece, existe alguma maneira de corrigir?

    Patch Captive Portal This feature was removed - see Bug #5594 for details!
    If you were using this feature, double-check '/etc/inc/captiveportal.inc' content for sanity.
    Get a sane copy of the file from pfSense GitHub repository if needed.



  • olá Amigo,

    Verifique esses posts e veja se te ajuda..

    • Patch captive portal para Squid.

    https://forum.pfsense.org/index.php?topic=103745.msg578553#msg578553

    https://forum.pfsense.org/index.php?topic=92497.0

    Se depois que aplicar o patch e o serviço do squid não iniciar, realize os links abaixo, atentando-se na versão do seu pfsense (AMD64 ou I386).

    rm /usr/pbi/squid-amd64/bin/check_ip.php
    cp /usr/local/bin/check_ip.php /usr/pbi/squid-amd64/bin/
    ln -s /usr/local/bin/php /usr/pbi/squid-amd64/local/bin/php
    ln -s /usr/local/lib/php /usr/pbi/squid-amd64/local/lib/php
    ln -s /usr/local/etc/php.ini /usr/pbi/squid-amd64/local/etc/php.ini
    ln -s /usr/local/lib/libsqlite3.so.0 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libintl.so.8.1.14 /usr/pbi/squid-amd64/lib/libintl.so.8
    ln -s /usr/local/lib/libmcrypt.so.4 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libonig.so.1 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libsodium.so.13 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libssh2.so.1 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/ipsec/libvici.so.0 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libzmq.so.5 /usr/pbi/squid-amd64/lib

    • Configuração do servidor Radius ( utilize se precisar integrar com o Active Directory )

    https://forum.pfsense.org/index.php?topic=56238.0

    Acho que é isso.. Espero ter ajudado,

    Abraços,

    Diego



  • complementando,

    faltou mais um detalhe.. Para o captive portal funcionar com o squid é necessário liberar um endereço para que este não passe pelo proxy, como exemplo o site da empresa, para que com isso ao abrir o navegador o site chamado seja esse.

    Abraços,

    Diego



  • A duvida pode ser bem leiga, mas tenho que fazer, pra que serve e patch captive portal?



  • @didonsom:

    olá Amigo,

    Verifique esses posts e veja se te ajuda..

    • Patch captive portal para Squid.

    https://forum.pfsense.org/index.php?topic=103745.msg578553#msg578553

    https://forum.pfsense.org/index.php?topic=92497.0

    Se depois que aplicar o patch e o serviço do squid não iniciar, realize os links abaixo, atentando-se na versão do seu pfsense (AMD64 ou I386).

    rm /usr/pbi/squid-amd64/bin/check_ip.php
    cp /usr/local/bin/check_ip.php /usr/pbi/squid-amd64/bin/
    ln -s /usr/local/bin/php /usr/pbi/squid-amd64/local/bin/php
    ln -s /usr/local/lib/php /usr/pbi/squid-amd64/local/lib/php
    ln -s /usr/local/etc/php.ini /usr/pbi/squid-amd64/local/etc/php.ini
    ln -s /usr/local/lib/libsqlite3.so.0 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libintl.so.8.1.14 /usr/pbi/squid-amd64/lib/libintl.so.8
    ln -s /usr/local/lib/libmcrypt.so.4 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libonig.so.1 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libsodium.so.13 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libssh2.so.1 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/ipsec/libvici.so.0 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libzmq.so.5 /usr/pbi/squid-amd64/lib

    • Configuração do servidor Radius ( utilize se precisar integrar com o Active Directory )

    https://forum.pfsense.org/index.php?topic=56238.0

    Acho que é isso.. Espero ter ajudado,

    Abraços,

    Diego

    como realizo esse links no i386?



  • @VictorM:

    A duvida pode ser bem leiga, mas tenho que fazer, pra que serve e patch captive portal?

    Esse patch serve para integrar o squid com o captive portal.
    O mesmo tem que ser aplicado manualmente em virtude do bug #5594. Esse patch é uma contribuição do Marcelloc, o "ninja" do PFSENSE :) e moderador do fórum.

    Em relação aos links…

    já tentou alterar aonde está AMD64 para I386 ? nessa parte não vou conseguir te ajudar, pq a muito tempo não utilizo o pfsense I386

    abraços,

    Diego



  • @didonsom:

    Esse patch serve para integrar o squid com o captive portal.
    O mesmo tem que ser aplicado manualmente em virtude do bug #5594. Esse patch é uma contribuição do Marcelloc, o "ninja" do PFSENSE :) e moderador do fórum.

    Em relação aos links…

    já tentou alterar aonde está AMD64 para I386 ? nessa parte não vou conseguir te ajudar, pq a muito tempo não utilizo o pfsense I386

    abraços,

    Diego

    Diego eu tentei adicionar manualmente o patch e me veio esse erro o que devo fazer ?

    Patch can NOT be applied cleanly (detalhe)
    Patch can NOT be reverted cleanly (detalhe)

    Em relação aos links eu pensei na ideia de mudar pra i386, mas minha duvida foi tipo, como eu realizo ele, desculpa a leiguice mas é que sou novo nisso.

    Desde ja muito grato pela sua ajuda.



  • @VictorM:

    @didonsom:

    Esse patch serve para integrar o squid com o captive portal.
    O mesmo tem que ser aplicado manualmente em virtude do bug #5594. Esse patch é uma contribuição do Marcelloc, o "ninja" do PFSENSE :) e moderador do fórum.

    Em relação aos links…

    já tentou alterar aonde está AMD64 para I386 ? nessa parte não vou conseguir te ajudar, pq a muito tempo não utilizo o pfsense I386

    abraços,

    Diego

    Diego eu tentei adicionar manualmente o patch e me veio esse erro o que devo fazer ?

    Patch can NOT be applied cleanly (detalhe)
    Patch can NOT be reverted cleanly (detalhe)

    Em relação aos links eu pensei na ideia de mudar pra i386, mas minha duvida foi tipo, como eu realizo ele, desculpa a leiguice mas é que sou novo nisso.

    Desde ja muito grato pela sua ajuda.

    em relação ao patch, você tem que clicar em apply e não em test.

    para aplicar os links, Acesse diagnostic > command adicione o link na primeira linha e clique em execute.

    • Antes de executar esse procedimento, veja se o serviço do squid está funcionando.

    que versão do pfsense você está utilizando?

    abraços,

    Diego



  • Utilizo a versão 2.2.6



  • Como faco pra saber se meu patch ta funcionando? por que ja fiz de tudo e mesmo assim ele não abre, quando coloco em autenticacao local ele abre o site sem passar pelo proxy como eu configurei na firewall, mas quando mudo a autenticacao pra captive portal ele da erro de proxy, como se nao tivesse encontrando, nao sei mais o que fazer, alguem me ajuda?



  • Galera, alguem porfavor me ajude, ja fiz de tudo e mesmo assim o portal captive nao funciona com proxy, quando eu coloco pra fazer autenticacao local ele faz, ai coloque uma pagina pra nao passar pelo o squid e tmb foi mas quando mudo a autenticacao pra captive portal ele nao abre, nao sei mais o que fazer alguem porfavor me ajuda? Estou desesperado pq esta meu trabalho em jogo.

    Grato,

    Victor.



  • @VictorM:

    Galera, alguem porfavor me ajude, ja fiz de tudo e mesmo assim o portal captive nao funciona com proxy, quando eu coloco pra fazer autenticacao local ele faz, ai coloque uma pagina pra nao passar pelo o squid e tmb foi mas quando mudo a autenticacao pra captive portal ele nao abre, nao sei mais o que fazer alguem porfavor me ajuda? Estou desesperado pq esta meu trabalho em jogo.

    Grato,

    Victor.

    Amigo,

    Se ninguém respondeu é q provavelmente não saibam como resolver! Tente procurar no fórum internacional para ver se alguém já passou por esse problema!

    Abraços,

    Diego



  • Diego voce pode me passar um contato seu? vi em um topico que voce conseguiu o que eu preciso, assim eu consigo fazer ele funcionar com autenticacao local so nao com o captive



  • @VictorM:

    Diego voce pode me passar um contato seu? vi em um topico que voce conseguiu o que eu preciso, assim eu consigo fazer ele funcionar com autenticacao local so nao com o captive

    eu tinha respondido seu e-mail com o whats me add la …

    abs

    diego



  • Nao chegou nenhum email aque

    Manda nesse victor_vcm@hotmail.com



  • @didonsom:

    olá Amigo,

    Verifique esses posts e veja se te ajuda..

    • Patch captive portal para Squid.

    https://forum.pfsense.org/index.php?topic=103745.msg578553#msg578553

    https://forum.pfsense.org/index.php?topic=92497.0

    Se depois que aplicar o patch e o serviço do squid não iniciar, realize os links abaixo, atentando-se na versão do seu pfsense (AMD64 ou I386).

    rm /usr/pbi/squid-amd64/bin/check_ip.php
    cp /usr/local/bin/check_ip.php /usr/pbi/squid-amd64/bin/
    ln -s /usr/local/bin/php /usr/pbi/squid-amd64/local/bin/php
    ln -s /usr/local/lib/php /usr/pbi/squid-amd64/local/lib/php
    ln -s /usr/local/etc/php.ini /usr/pbi/squid-amd64/local/etc/php.ini
    ln -s /usr/local/lib/libsqlite3.so.0 /usr/pbi/squid-amd64/local/lib/
    ln -s /usr/local/lib/libintl.so.8.1.14 /usr/pbi/squid-amd64/lib/libintl.so.8
    ln -s /usr/local/lib/libmcrypt.so.4 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libonig.so.1 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libsodium.so.13 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libssh2.so.1 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/ipsec/libvici.so.0 /usr/pbi/squid-amd64/lib
    ln -s /usr/local/lib/libzmq.so.5 /usr/pbi/squid-amd64/lib

    • Configuração do servidor Radius ( utilize se precisar integrar com o Active Directory )

    https://forum.pfsense.org/index.php?topic=56238.0

    Acho que é isso.. Espero ter ajudado,

    Abraços,

    Diego

    Realmente depois que coloque o path ele nao inicia mais, tentei mudar pra i386 mas nao deu certo.

    alguma dica?



  • @VictorM:

    Realmente depois que coloque o path ele nao inicia mais, tentei mudar pra i386 mas nao deu certo.

    se fez o link para a versão errada (amd64 quando está usando a i386), vai ter que corrigir isso antes de fazer os links novamente….



  • Mas como corrijo isso, ja tentei mudar onde esta amd64 para i386 mas não deu certo



  • Qual é a versão do pfSense que você instalou?



  • @marcelloc:

    Qual é a versão do pfSense que você instalou?

    A versão 2.2.6



  • I386 ou amd64?



  • I386



  • Alguma solução para ele ficar ligado e funcionando?



  • @VictorM:

    Alguma solução para ele ficar ligado e funcionando?

    Sim. Basicamente fazer o link das libs na versão certa. Depois de misturar arquiteturas diferentes é bem complicado te dar um passo a passo de como desfazer isso fora reinstalar do zero.



  • @marcelloc:

    @VictorM:

    Alguma solução para ele ficar ligado e funcionando?

    Sim. Basicamente fazer o link das libs na versão certa. Depois de misturar arquiteturas diferentes é bem complicado te dar um passo a passo de como desfazer isso fora reinstalar do zero.

    E como são essas libs para versão 2.2.6  i386 ?



  • @VictorM:

    E como são essas libs para versão 2.2.6  i386 ?

    Victor, sugiro fazer um curso sobre pfSense ou até mesmo sobre linux/redes para entender melhor os conceitos.

    Se você manda o Sistema operacional fazer o link de um arquivo que não existe, você vai ter problemas com certeza.

    Pesquisando pouco tempo no fórum, achei um dos tópicos que descreve com precisão os links necessários a se fazer.

    https://forum.pfsense.org/index.php?topic=107357.msg602412#msg602412


Log in to reply