Problema con squidguard



  • Hola a todos, nuevamente buscando un poco de ayuda, en el foro.

    Estoy intentando desinstalar el paquete de squid y squidguard, para luego volver a instalarlo y solventar un error que estoy teniendo, pero cada vez que vuelvo a instalar tengo la misma configuración que en las instalaciones anteriores. Alguien me podria ayudar diciendome que otros archivos deberia borrar a mano para que cuando vuelva a instalar el paquetes squidguard la configuracion este por defecto?

    Muchas gracias.



  • Hola.

    Nota: Para desinstalar Squid, con o sin mantener la configuración de Squid > Services > Squid Proxy Server y desmarcar Keep Settings/Data si no deseas mantener la conf.

    Si deseas desinstalar Squid y que no repita la conf, desmarca enable, desmarca keep Settings/Data, salva y desinstala el paquete.



  • Hola javcasta, no tengo esta opción en mi pfsense. Tu tienes squid3, yo uso solo squid.

    Muchas gracias por responder.



  • Hola.

    Mira el post: https://forum.pfsense.org/index.php?topic=78521.msg428348#msg428348

    Lo que dice es: Vas al menú Diagnostics: Execute command >  PHP Execute: y ejecutas para remover las confs, el código:

    
    $squid_sections = array("squid", "squidnac", "squidcache", "squidauth", "squidextauth", "squidtraffic", "squidupstream", "squidusers");
    foreach ($squid_sections as $sec) {
    	if (is_array($config['installedpackages'][$sec]))
    		unset($config['installedpackages'][$sec]);
    }
    write_config("Removed Squid");
    
    

    Para remover los paquetes las configuraciones de cualquier servicio relativo a squid,ejecutarias el código:

    foreach (array_keys($config['installedpackages']) as $sec) {
    	if (strpos($sec, "squid") !== false)
    		unset($config['installedpackages'][$sec]);
    }
    write_config("Removed all squid-related settings");
    
    

    Comenta el que postea, que no es perfecto el procedimiento, pero que funciona.

    –- añadido ---

    No lo he probado, pero por lo que leo, borrando:

    /var/squid
    /usr/local/pkg/squid.*
    /usr/local/pkg/squid_.
    /usr/local/pkg/squid*

    Te "cargas" la conf de squidguard (y de squid, claro,... una vez hecho eso, yo pobaria a desinstalar paquetes y volver a instalarlos

    Salu2



  • Hola.

    He probado a ejecutar:

    foreach (array_keys($config['installedpackages']) as $sec) {
    	if (strpos($sec, "squid") !== false)
    		unset($config['installedpackages'][$sec]);
    }
    write_config("Removed all squid-related settings");
    
    

    Y efectivamente, elimina todas las conf de squid y SquidGuard (curiosamente los servicios squid, squidGuard y clamavd, siguen activos). Luego imagino que desistalando los paquetes y reiniciando ya estaria todo "fresco"

    Salu2



  • Hola Jav, muchas gracias por este aporte, funciono correctamente, elimino todo tipo de configuración de squid. Volví a instalar los paquetes y tuve que volver a configurar los, mi vieja configuración ya no existía, pero por algún motivo cuando mi servidor filtra sigue dando el mismo problema.

    Cuando un usuario intenta abrir una pagina que esta filtrada, en vez de devolverle por que esta filtrado, envía el mensaje que te adjunto.




  • Hola.

    Prueba a borrar la caché del squid y volver a crearla (y de paso la del/los navegador/es del/los cliente/s )

    Un procedimiento para eso (aunque es de squid3 se aplicaria tb a squid):

    https://www.javcasta.com/procedimiento-de-borrado-y-creacion-de-cache-de-squid-squid3-en-pfsense-2-2-6/

    Salu2



  • Hola javcasta, ya había probado esto.

    Te agradezco tu colaboración.

    Cambien intente esto que mencionan aquí y no va!

    http://drivemeca.blogspot.com.ar/2014/03/como-personalizar-error-de-squidguard.html

    Un saludo



  • Hola.

    El tema es que el error respuesta vacia, tamaño 0. Suele ser un erro de caché (por lo que he leido), y el enlace ese habla de como personalizar la página de error (nada que ver)…

    En la FAQ de Squid:

    Why do I sometimes get "Zero Sized Reply"? http://wiki.squid-cache.org/SquidFaq/TroubleShooting#Why_do_I_sometimes_get_.22Zero_Sized_Reply.22.3F

    Y aquí puede que esté el meollo del asunto: Que TCP blackholing esté activo en FreeBSD (pfSense se basa en FreeBSD)
    "Zero Sized Reply" error due to TCP blackholing" in FreeBSD
    http://wiki.squid-cache.org/SquidFaq/SystemWeirdnesses#A.22Zero_Sized_Reply.22_error_due_to_TCP_blackholing

    He probado y resulta que por defecto en pfSense 2.2.6 TCP blackholing está activo.

    Para desactivarlo

    # /sbin/sysctl net.inet.tcp.blackhole=0
    

    Y para que al reinicio siga desactivado, editar /etc/sysctl.conf y poner net.inet.tcp.blackhole a 0

    To make sure the setting survives across reboots, add the following line to the file /etc/sysctl.conf:

    net.inet.tcp.blackhole=0

    Salu2



  • Muchas gracias por la ayuda, lamentablemente esto tampoco funciono, creo que voy a tener que re instalar el servidor, el problema es que esta a 1500KM.



  • Hola.

    ¿No hay nadie que te instale la configuración básica para poder acceder en remoto?
    Uf, bon voyage … si me entero de algo más te cuento, pero yo que tu indagaria en la FAQ de squid-cache en su sección FreeBSD

    http://wiki.squid-cache.org/SquidFaq/SystemWeirdnesses#FreeBSD

    Y en este foro: busca "squid zero reply size" (hay mucha info en inglés)

    Suerte y Salu2



  • Creo que  podria guiar para que hagan la instalación básica con servicio de internet para después tomarlo remoto. Todo esto ocurrió después de un corte de energía.

    Muchas gracias por la ayuda!



  • Hola.

    ¿Tienes backup?  :) (si lo tienes, instalar de 0 pfSense, y restaurar el xml del backup, suele ir muy bien, no es perfecto, poero te ahorras unas horas)

    De nada y Salu2.