Problema con PING da SERVER e OPENVPN



  • Salve a tutti.
    Ho un problema di questo genere con il pfsense, in particolare con la configurazione di OPENVPN

    premetto che l'ho ereditato e quindi ho seguito la logica con cui i server OPENVPN erano creati.

    La rete nel firewall pfsense è una 192.168.40.X/24

    La rete connessa, è stata configurata come server sul TUNNEL 10.76.0.8/30
    Il certificato è stato messo sul firewall della rete B, e la rete è una 192.168.42.X/24

    Le macchine da entrambe le parti si pingano regolarmente.

    Allo stesso modo, ho creato un nuovo certificato server, con TUNNEL 10.76.0.44/30
    La rete di questo, considerando che è un pc da solo con openvpn a bordo è dettata dalla chiavetta quindi un 192.168.0.X/24

    Il pc vede regolarmente la rete con tutti i pc della rete sulla quale si è connesso.
    I pc all'interno della rete invece vedono solamente gli ip 10.76.0.45 e 46, in pratica gli ip server e cliente del tunnel,
    ma le macchine all'interno, non pingano l'indirizzo ip 192.168.0.x del pc connesso.

    Le route le ho controllate, in diagnosti/routes,  il routing punta in modo corretto al gateway del tunnel.

    Come mai 2 certificati uguali si comportano in modo diverso?



  • Ciao,
    non è molto chiara la tua descrizione, uno schema della rete potrebbe aiutare.
    Ho visto che usi la parloa certificati per intendere server vpn e questo non aiuta.

    se non ho capito male hai 3 sedi:
    A che ha come LAN 192.168.40.0/24;
    B che ha come LAN 192.168.42.0/24;
    C che ha come LAN 192.168.0.0/24.

    Ora una di queste sarà la sede centrale su cui hai OpenVPN in modalità server e le altre due saranno in modalità client.
    Come sono organizzate?

    Fabio



  • Ciao,

    grazie per l'interessamento innanzi tutto,
    sono riuscito a schiarirmi le idee.
    La rete non poteva funzionare, in quanto io nelle sedi client, non avevo installato il pfsense ma solamente il programma OPENVPN su un pc.
    Concettualmente volevo una site to site, ma in pratica cosi facendo la rete diveniva una client -server

    Ho risolto inserendo nelle sede remota un pfsense virtualizzato, e messo i parametri di client e tutto funziona.

    Per ora grazie.