Freeradius2 no inicia automaticamente



  • php: rc.bootup: ROUTING: setting default route to 192.168.1.1
    kernel: done.
    kernel: done.
    kernel: done.
    check_reload_status: Updating all dyndns
    kernel: ipfw2 (+ipv6) initialized, divert loadable, nat loadable, default to accept, logging disabled
    lighttpd[47330]: (log.c.194) server started
    php: rc.bootup: Creating rrd update script
    syslogd: exiting on signal 15
    syslogd: kernel boot file is /boot/kernel/kernel
    kernel: done.
    kernel: done.
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    radiusd[77720]: Loaded virtual server <default>radiusd[84624]: Ready to process requests.
    radiusd[84624]: Signalled to terminate
    radiusd[84624]: Exiting normally.
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    php-fpm[246]: /rc.start_packages: The command '/usr/local/etc/rc.d/radiusd.sh stop' returned exit code '1', the output was 'radiusd not running?'
    login: login on ttyv0 as root

    cada vez que reinicia el servidor tengo que iniciar el radius manualmente (copie el log que me da) alguien sabe como solucionarlo? o la fuente donde esta la solucion… gracias</default>



  • Nosotros teníamos ese problema. Lo que veíamos es que el servicio inicia correctamente, pero el script de arranque después va y lo para.  :o
    Lo resolvimos con un watchdog.
    Hay un hilo en inglés https://forum.pfsense.org/index.php?topic=87441.msg546710#msg546710

    Instalas el paquete "Service Watchdog"
    Te vas a Services - Service Watchdog y añades el servicio freeradius a la lista de servicios monitorizados.
    El Watchdog vigila que los servicios en su lista estén arrancados siempre.
    Si no los ven arrancados los arranca.
    De esta forma al iniciar el sistema, como el watchdog detecta el freeradius no está iniciado, te lo arranca. Nosotros tenemos este servicio monitorizado  por lo mismo que dices tu, y el DNS Forwarder porque con la cantidad de usuarios que tenemos, en ocasiones nos cruje.


Log in to reply