[Solved] squid blocks all internet connection when I activated Transparent prox



  • Hello experts. As I mentioned on the subject of the topic, I'm having a problem with transparent proxy. I had uninstalled squid and deleted the leftover folders, I reinstalled again and still it the problem is occured.

    I have two questions
    1-When I uninstall squid, squidguard etc. the configs is not deleted. When I reinstall squid I see the last configurations are still there. I wanna remove all of them and want a clean install.
    2-How can I fix the problem is occured when I activated transparent proxy.

    Thanks.

    –------------------------------

    Solution;

    Limiter is causing to the issue. Remove the limiter and use this link https://forum.pfsense.org/index.php?topic=106640.0 to limit your bandwith with squid+squid guardian------------------



  • 1.  This question has nothing to do with the firewall and should instead be in the Cache/Proxy forum.

    2. Transparent proxy is a bad idea because it won't do HTTPS unless you install a pfSense certificate in every device that will use the proxy.  Make squid run in explicit mode and configure WPAD instead, or manually configure your clients to use the proxy.

    3.  If you insist on using transparent mode, squid often requires a service restart (or reboot) after initial installation.  Also, make sure you're running squid3 and not ancient squid (which is based on 2.7).  If you have done all of these and it still has problems, shell in (option 8 from console) and check /var/squid/logs/access.log and cache.log, as well as the system log (Status - System logs - System).



  • I thank you for warning for that the topic is in the wrong section. I did not know where I should ask this q. I'm asking the mods to move this topic to the right place.

    The thing is here I can't use proxy, because there are laptops connecting to the internet by DHCP and setting manual proxy loads tons of work on my shoulders. You are right about HTTPS but for now I have to block https adresse manualy. I was using older squid but I had installed squid3 after having the problem, the result? is the same. The problem is the log files does not specify the issue but I'll look at it again.

    What about deleting the old settings? How can I do that?



  • because there are laptops connecting to the internet by DHCP and setting manual proxy loads tons of work on my shoulders.

    That's why you would configure WPAD so that your clients can auto-discover the proxy on their own.  You can also deliver the proxy auto-configure URL address via DHCP option 252.

    What about deleting the old settings? How can I do that?

    https://forum.pfsense.org/index.php?topic=78521.msg429151#msg429151



  • Thank you for your help. The article and your words took me to another step.