[SOLVED] Add one of OpenVPN interfaces as pfSense interface



  • Hi!

    Searched high and low and can't find if this is even an valid option. Please direct me if the info is available as my google-fu is letting me down  :( .

    "Interface/(assign)/Available network ports" and adding for example "opvpns2()" which is a OpenVPN server instance.

    I would like to do this because monitoring and rules specific to a OpenVPN instance. I've got multiple site-to-site (client and server) and user-client-connect OpenVPNs running.

    Brgs,


  • LAYER 8 Global Moderator

    why do you not just look at the assign interface tab - you can clearly assign a openvpn instance to a opt interface..

    As you can see I have my vpn client vpn connection assigned to an interface I call ns1vpn, and I have 2 other openvpn instances I could assign to interfaces as well.




  • Did that and got all sort of problems. Tried it with one och server interfaces. A new rules tab comes available for that OPT. Set IPv4 any-any, but could not get it to pass traffic to the LAN after that. Something I'm missing here?


  • LAYER 8 Netgate

    When you do create an openVPN assigned interface it is disruptive to the VPN. You need to stop and restart that OpenVPN service afterwards.

    https://www.infotechwerx.com/blog/Creating-OpenVPN-Assigned-Interface



  • Hi!
    Thank you. That solved the weirdness I experienced the first time I tried this.

    My procedure went like this.

    • Assign the OpenVPN server interface to an OPT

    • Enabled and renamed the OPT. Left the IPv4/v6 config, defaults, to "none"

    • Restarted the OpenVPN instance for the interface

    Works as before, traffic is passed as it should.

    No rules added to the new interface. I presume the overall rule for OpenVPN is still acting on this interface(?)

    I suppose adding rules to the assigned interface allows us to have specific rules for that OpenVPN instance?

    Brgs,


  • LAYER 8 Netgate

    You're better off if rules on the OpenVPN tab don't match traffic for the assigned interface.

    I generally delete all the rules on the OpenVPN tab when I use assigned interfaces.


Log in to reply