[SOLVED]VoIP phone not registering with outside PBX



  • Hello,

    Later edit:
    It seems that with siproxd the phone registers with the outside PBX and audio is ok.
    Had a hard time figuring out siproxd because this is my first time I needed to register a voip phone in this manner.
    Sorry for opening a useless thread.

    Given that PFSense 2.3 beta is the only distro that works with my M.2 SSD and my two Intel nics (211 & 219), I have to use it until a stable comes along.
    The problem is that my Cisco SPA502G does not register at all with the PBX.
    The PBX is not local, but hosted in DC.

    As far as I can tell from the PBX (3CX) logs, the phone does not even reach the PBX. No register attempt is being made.
    As soon as I plug my old Asus RT-AC68U, the phone registers instantly.

    I have tried setting the firewall optimization to "conservative" and tried all Outbound NAT options to no avail.

    Any hint what must I do to allow my VoIP phone to register with an outside PBX? And for that mater, what can cause such a behavior with PFSense?

    Thank you.



  • How did you resolve this?



  • Install siproxd from Package Manager.
    Enable it.
    In Services/siproxd I have modified only:
    1. Enable proxy authentication
    2. Input your PBX IP or fqdn and the port (usually 5060)

    The rest I left at default values.
    Make sure Inbound and Outbound interfaces are setup properly on the same page.

    If everything checks out, you should see your phone connections in "Registered Phones" section.
    For me at least, without "Enable proxy authentication", calls from an outside line to my PBX could not be answered. The phone rang, but I wasn't able to answer the call.
    On the VoIP phone, you should setup your registration details for the actual PBX, not the siproxd machine. Do not create an account in siproxd.



  • That's the answer for what's needed if you have to rewrite the private IPs within the SIP packets to your public IP. Whether you need that depends on the provider and situation. It's usually not necessary or desirable to use siproxd.

    This case may have been resolved by just using static port for the SIP and/or RTP traffic, though no traffic reaching the PBX at all would indicate an entirely different problem that siproxd wouldn't solve either.

    The usual suspects here if the defaults don't work.
    https://doc.pfsense.org/index.php/VoIP_Configuration


Log in to reply