Problème VPN - OpenVPN



  • Bonsoir,

    Je souhaite mettre en place un VPN site to site. Pour cela je compte utiliser Pfsense 2.6 et le protocol OpenVPN. Pour faire simple, mon VPN aura pour rôle de permettre à des utilisateurs situés sur un point B d'avoir accès aux données stockées sur un point A. J'ai créer ma liaison VPN, cependant j'aurais besoin d'aide pour m'éclairer dans plusieurs zone d'ombre comme le firewall, le cryptage ect..

    Serait-il possible de bénéficier de retour d'expérience / conseils pour se genre de tâche ?

    Merci d'avance !



  • Je ne comprend pas ce que vous voulez savoir.



  • Effectivement la question  n'est pas très claire.

    Au fait, pourquoi OpenVPN plutôt que IPSec ?

    Avec pfSense, les règles au niveau du FW sont les mêmes que pour une interface classique. Quelles sont tes interrogations ?

    Pour ce qui est du choix des algorithmes de cryptage, c'est avant tout une histoire d'équilibre entre la longueur de clé et le hardware car l'impact est principalement en termes de performance.
    Selon le débit qu tu vises et le hadware dont tu disposes, si tu peux faire du AES-256 bit, c'est bien. Si tu es obligé de dégrader sur du DES 64 bit pour maintenir ton débit, il faut changer de hardware  ;D



  • Bonjour,

    Je n'ai pas choisit pour le protocol, c'est dans mon cahier des charges. Je te remercie pour l’explication sur le cryptage.

    J'ai commencer à créer mon VPN mais mes deux sites ne communiquent pas, avez vous idées d’où ça pourrait venir ?



  • Bonsoir Hommebleu,

    Dans le cadre d'un projet pédagogique j'ai eu à mettre en place une solution similaire tienne, je vais donc essayer comme je peux de t'aider. Cependant un schéma avec le plan d’adressage serait le bienvenu pour que l'on puisse se situé dans ton architecture.

    Tu dis que tes deux sites ne communiquent pas, as tu pensé à vérifier que les règles de tes firewalls autorisait cette communication des deux côtés ?

    Si oui :

    • Commence par ping sur chacun de tes deux sites chaque éléments de tes réseaux internes (routeur,switch,machines,serveurs..)

    Cela te permettra de localiser d’où vient le problème car le problème ne vient peut-être pas de ton VPN.

    Cordialement,

    Steven



  • @Steven_:

    Bonsoir Hommebleu,

    Dans le cadre d'un projet pédagogique j'ai eu à mettre en place une solution similaire tienne, je vais donc essayer comme je peux de t'aider. Cependant un schéma avec le plan d’adressage serait le bienvenu pour que l'on puisse se situé dans ton architecture.

    Tu dis que tes deux sites ne communiquent pas, as tu pensé à vérifier que les règles de tes firewalls autorisait cette communication des deux côtés ?

    Si oui :

    • Commence par ping sur chacun de tes deux sites chaque éléments de tes réseaux internes (routeur,switch,machines,serveurs..)

    Cela te permettra de localiser d’où vient le problème car le problème ne vient peut-être pas de ton VPN.

    Cordialement,

    Steven

    Bonsoir,

    Je te remercie pour tes conseils ils m'ont été bien utile ! Je m'explique :

    • Comme tu me la recommandé, j'ai vérifié mes réseaux internes et j'ai effectivement vu qu'il y avait quelques problèmes au niveau de certains équipements comme mes switchs et mon routeur.. je pensais qu'il était normal que je n'ai pas internet et que je ne les pings pas mais apparemment non vu que maintenant c'est le cas et j'ai bien internet !

    Maintenant que je sais que mes réseaux internes sont ok je regarderais la semaine prochaine pour se qui est des règles et mes paramètres OpenVPN.

    Je vous tiens au courant, bon week-end !



  • Bonsoir,

    Je m'excuse de ne pas avoir pu revenir vers vous plus tôt mais Steven tu avais raison j'avais bel et bien un problème au niveau des règles de mon pfsense.

    L'une de mes règles n'autorisais pas la communication vers mon autre site (j'ai honte).

    En tout cas je vous remercie, ça marche niquel !