IPv6 route weirdness



  • Hi all!

    Can anybody explain this error messages for me please?
    My ipv6 is working just fine via pppoe.

    /rc.start_packages: The command '/sbin/route change -inet6 default fe80::2c1:64ff:fed8:3f00' returned exit code '1', the output was 'route: writing to routing socket: Network is unreachable route: writing to routing socket: Network is unreachable change net default: gateway fe80::2c1:64ff:fed8:3f00 fib 0: Network is unreachable'

    rc.bootup: The command '/sbin/route change -inet6 default fe80::2c1:64ff:fed8:3f00' returned exit code '1', the output was 'route: writing to routing socket: Network is unreachable route: writing to routing socket: Network is unreachable change net default: gateway fe80::2c1:64ff:fed8:3f00 fib 0: Network is unreachable'

    /status_ipsec.php: The command '/sbin/route change -inet6 default fe80::2c1:64ff:fed8:3f00' returned exit code '1', the output was 'route: writing to routing socket: Network is unreachable route: writing to routing socket: Network is unreachable change net default: gateway fe80::2c1:64ff:fed8:3f00 fib 0: Network is unreachable'



  • Use non-local gateway through interface specific route.

    I checked this and those warnings went away?
    Am I doing something wrong here?



  • I've seen that in passing before, it just seems to be log spam. I haven't seen a means of replicating. If it doesn't cause any problems, it's safe to ignore, but if it's something you continue to get I'd like to know under what circumstance.



  • Hi!

    Use non-local gateway through interface specific route, this option enabled and I get only 2 warnings during bootup and that`s it, no more.

    What I think is happening:

    I use pppoe ipv6 and when device boots it sets default gateway to fe80::2c1:64ff:fed8:3f00 but errors, because pppoe is not yet fully initialised (first ipv4 and then ipv6).

    Also fe80::2c1:64ff:fed8:3f00 is not on the same subnet as IPv6 address on pppoe iface so that is why I was getting errors, and use non local gateway checked shut it up.


Log in to reply