Problemas Instalación de PFblockerNG



  • Señores,
    tengo el siguiente problema. Al desintalar PfblockerNG queda en este estado y no me da el OK.
    se queda pegado en:

    Removing package…
    Starting package deletion for pfblockerng-1.6.6-i386...done.
    Removing pfBlockerNG components...
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...

    Crash report details:

    PHP Errors:
    [17-Mar-2016 14:29:22 America/Santiago] PHP Fatal error:  require_once(): Failed opening required '/usr/local/pkg/pfblockerng/pfblockerng_extra.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/pkg/pfblockerng/pfblockerng.inc on line 47

    alguien me puede ayudar??
    gracias de antemano.



  • Hola.

    Podrias intentar esto. Ejecutar desde Diagnostics Command prompt > PHP Execute:

    foreach (array_keys($config['installedpackages']) as $sec) {
    	if (strpos($sec, "pfblockerng") !== false)
    		unset($config['installedpackages'][$sec]);
    }
    write_config("Removed all pfblockerng-related settings");
    

    Se supone que borraria la conf del pfblocker y vuleves a instalarlo, pero no estoy seguro, no lo he probado.

    Otro problema similar, mismo error, pero para el paquete Suricata:
    https://forum.pfsense.org/index.php?topic=99398.0

    Salu2



  • Muchas Gracias, lo revisaré!


  • Moderator

    Sorry for not writing in Spanish :)

    The issue here, is that the file: /usr/local/pkg/pfblockerng/pfblockerng_extra.inc  is missing.

    To replace the missing file, you can run the following command:

    fetch -o /usr/local/pkg/pfblockerng/pfblockerng_extra.inc https://packages.pfsense.org/packages/config/pfblockerng/pfblockerng_extra.inc
    

    I have not seen this error before, do you have any other details? Was pfBlockerNG installed and working before you removed it? Was this a de-install or a re-install?

    Thanks!



  • Hola/Hello.

    Thanks for the solution. :)

    Regards.


  • Moderator

    De nada, fue un placer.  ;)


Log in to reply