• hi.
    pfsense 2.3 installed on esxi 5.5 host hangs after restart.

    the error i'm getting is:

    mpt0: Timedout requests already complete. Interrupts may not be functioning

    if i turn the vm off and on again, it boots as expected.

    should i file a bug report?

  • Rebel Alliance Developer Netgate

    That would be an issue with the virtual hardware on FreeBSD and ESX, nothing can do for that, especially since it's storage-related. You might try a plain FreeBSD install to see what happens.

    IIRC some people have had issues with FreeBSD 10.x on ESX 5.x, might be time to move your ESX install up to 6.x.


  • @jimp:

    You might try a plain FreeBSD install to see what happens.

    plain FreeBSD reboots with no problems

  • Rebel Alliance Developer Netgate

    And you're certain the VM hardware and VM version is identical in both those cases?


  • Absolutely. I even tried to copy the vmdk between machines. vmdk with pfsense 2.3 installed hangs on reboot while vmdk with freebsd 10.3  - RC3 reboots as expected.


  • Something isn't equivalent between them. That's in part of FreeBSD that's completely stock, there has to be some diff between your 2.3 and 10.3 VMs if they don't behave the same in that regard. Lot of instances of people seeing that problem with stock FreeBSD if you search on it. For instance this among others.
    https://communities.vmware.com/thread/482834?start=0&tstart=0

    At a quick glance through search results on that log, I didn't see a recent case with a resolution, but I would suggest searching and looking closer at the results. There's something with your setup there that's causing that. ESX 5.5 works fine in general with 2.3.


  • for whoever experiences the same:

    setting hw.pci.enable_msix=0 and hw.pci.enable_msi=0 in System ->Advanced -> System Tunables solved the problem for me.
    YMMV.


  • Ram Disks Enabled?


  • Meaning? There are ram disks enabled by default

    
    Ramdisk Name  System  Include in Coredumps   Reserved     Maximum      Used  Peak Used  Free  Reserved Free  Maximum Inodes  Allocated Inodes  Used Inodes  Mount Point
    ------------  ------  --------------------  ---------  ----------  --------  ---------  ----  -------------  --------------  ----------------  -----------  ---------------------------
    root            true                  true  32768 KiB   32768 KiB  1012 KiB   1024 KiB  96 %           96 %            8192              4480         4406  /
    etc             true                  true  28672 KiB   28672 KiB   968 KiB   1012 KiB  96 %           96 %            4096              1024          475  /etc
    tmp            false                 false   2048 KiB  196608 KiB     4 KiB  10836 KiB  99 %           99 %            8192               256            3  /tmp
    hostdstats     false                 false      0 KiB  228352 KiB  3432 KiB   3500 KiB  98 %            0 %            8192                32            4  /var/lib/vmware/hostd/stats
    ~
    
    

  • I have problem on restarting with hyper-v after enable Ram Disk in Advanced > Miscellaneous. Some time i have to shutdown and power on to successfully run pFsense. Disable RAM Disks only failed one time  restarting the machine, after 10 ~ 20 or more (2.3 to 2.3) updates.

    Don't have any screen shots but my problems are in the Vlan Interfaces behave weird or reinstalling package or some more hanging behavior.

    So i give up having RAM disk enable, for now and maybe ever.


  • i generally wouldnt trust hyper-v as a virtualization platform…....
    what kind of error do you get when the guest hangs after restart?


  • @biGdada i don't remember. Should have dome some screen shots. Most of the time the problems are tagging VLAN Interfaces. Power off and power one solve the problem, the similarity to your resolution. Restarting it was not sufficient.

    Maybe latter i will try after build a new bare metal machine for pfSense, i can't do it now, sorry.