[Gelöst] Telekom - Entertain - IPTV Status: Offline


  • Habe mit pfSense eine schöne funktionierende Lösung für Telekom VoIP + IPTV konfiguriert.

    Leider lässt sich der Receiver nicht über den Programmmanager programmieren. Unter Mediareceiver > Netzwerk steht:

    IPTV Status: Offline
    

    Weiss jemand, wie sich das beheben lässt?


  • So, tut jetzt! Aufnahmen werden vom Programm Manager übertragen. :)

    Es lag wohl an meiner igmpproxy Konfiguration.

    Für die Konfig gibt es scheinbar zwei Dinge, die man grundsätzlich beachten muss:

    • Die Netze, die auf VLAN8 per DHCP propagiert werden

    • Das Netz 193.158.34.0/23[br/](/23 weil mittlerweile Adressen sowohl in 193.158.34.0/24 als auch in 193.158.35.0/24) kontaktiert werden

    Siehe auch https://forum.pfsense.org/index.php?topic=72200.msg400646#msg400646

    Der DHCP Client auf VLAN8 liefert bei mir so etwas (möglicherweise regional unterschiedlich):

    Mar 20 20:05:07 pfSense dhclient: New Classless Static Routes (bge0_vlan8):  193.158.132.189/32 10.37.255.254 87.141.128.0/17 10.37.255.254 217.237.157.0/24 10.37.255.254 217.237.158.0/24 10.37.255.254 217.239.36.0/24 10.37.255.254
    

    Damit ergibt sich für mein Netz folgende igmpproxy.conf:

    ##------------------------------------------------------
    ## Enable Quickleave mode (Sends Leave instantly)
    ##------------------------------------------------------
    quickleave
    
    # upstream / Telekom Netze
    phyint bge0_vlan8 upstream ratelimit 0 threshold 1
    altnet 193.158.132.189/32
    altnet 87.141.128.0/17
    altnet 217.237.157.0/24
    altnet 217.237.158.0/24
    altnet 217.239.36.0/24
    altnet 193.158.34.0/23
    
    # downstream / eigene Netze
    phyint igb2 downstream ratelimit 0 threshold 1
    altnet 192.168.11.0/24 # Receiver net
    
    phyint igb0 downstream ratelimit 0 threshold 1
    altnet 10.0.15.0/24 # net for VLC player
    
    phyint pppoe0 disabled
    phyint igb1 disabled
    phyint igb3 disabled
    phyint bge0 disabled
    phyint bridge0 disabled