• Hey
    I have set WPAD lightppd to autorun verify the two instances of lighttpd and all work fine
    I did configure the dhcp and dns forwarder for auto discover, test the WPAD host override works and is ok
    Create a firewall rule to prevent browsing via the usual HTTP and HTTPS port 80 445 ensuring all browsing is via proxy
    Change webgui HTTPS port to 5000
    Now when i set IE or Chrome for automatic detect proxy

    the autodetect dont work no internet on lan connected PC's only if i set manual proxy setiting and after that i have problem with the antivirus on client whio cant make update my SquidGaurd is set to deney access to social site only (facebook, twitter ..).
    Any solution for this problem.

    Thanks


  • try set pfsense Protocol to http.

    If that does not work try here

    https://forum.pfsense.org/index.php?topic=93060.0


  • @aGeekHere:

    try set pfsense Protocol to http.

    If that does not work try here

    https://forum.pfsense.org/index.php?topic=93060.0

    Thank's for fast reply i did try your solution before i post here read all your post and comments in your topic but seems to not work i dont know where is the problem from, for the webgui i tryed to change him to http (port:80) but still not work i was guessing problem was a conflit with the webconfigurator /usr/local/www/wpad/lighty-proxy-wpad.conf because Lighttpd instance is bind to my server, i did change port 80 to 81and also disabled WebGUI redirect but still same error


  • I think the issue is your lightppd if you let pfSense handle WPAD files and the DHCP and DNS either pfSense or windows server your good to go. Why dont you start first doing exactly from the guide that aGeekHere shows.


  • @killmasta93:

    I think the issue is your lightppd if you let pfSense handle WPAD files and the DHCP and DNS either pfSense or windows server your good to go. Why dont you start first doing exactly from the guide that aGeekHere shows.

    thank's for your replay
    As i have already said before i did try his solution before i post here but i got the same issue
    Client dont auto detect proxy


  • Create a firewall rule to prevent browsing via the usual HTTP and HTTPS port 80 445 ensuring all browsing is via proxy

    It's ports 80 and 443, not 445.

    Can your clients resolve wpad.yourdomain.tld?  Can your browsers fetch http://wpad.yourdomain.tld/wpad.dat?  What is the contents of your wpad.dat file?

    Bear in mind that wpad.dat must be served from an HTTP server, not HTTPS.


  • @KOM:

    Create a firewall rule to prevent browsing via the usual HTTP and HTTPS port 80 445 ensuring all browsing is via proxy

    It's ports 80 and 443, not 445.

    Can your clients resolve wpad.yourdomain.tld?  Can your browsers fetch http://wpad.yourdomain.tld/wpad.dat?  What is the contents of your wpad.dat file?

    Bear in mind that wpad.dat must be served from an HTTP server, not HTTPS.

    Thank's for replay yea sorry its port 443 and yea client can resolve wpad.mydomain.local also wpad they can also download the 3 files
    the content of my wpad.dat files is

    function FindProxyForURL(url, host) 
    { 
        if (isPlainHostName(host) ||
            shExpMatch(host, "*.local") ||
            isInNet(dnsResolve(host), "192.168.1.0",  "255.255.255.0"))
            return "DIRECT";
    
        return "PROXY 192.168.1.1:3128";
    }
    

  • Try clearing web browser cache

    Bear in mind that wpad.dat must be served from an HTTP server, not HTTPS.

    Very important and can be easily missed.


  • @aGeekHere:

    Try clearing web browser cache

    Bear in mind that wpad.dat must be served from an HTTP server, not HTTPS.

    Very important and can be easily missed.

    Well
    I did install new clean pfsense follow all your setps
    Clear cache in web browsers
    I have some client who can autodetect and others who still have the same issue  :o


  • I have some client who can autodetect and others who still have the same issue

    Are these other people using firefox? then add automatic proxy configuration url to the url of the wpad (like http://pfsense.mylocaldomain.local/wpad.dat) etc


  • @aGeekHere:

    I have some client who can autodetect and others who still have the same issue

    Are these other people using firefox? then add automatic proxy configuration url to the url of the wpad (like http://pfsense.mylocaldomain.local/wpad.dat) etc

    Thank's for your replay again
    Those clients users are using Chrome and IE


  • hmm..what operating system? the clients that have the issue can they resolve wpad? are these clients in a GPO environment? If so Could you try pushing them the proxy settings though GPO?


  • @killmasta93:

    hmm..what operating system? the clients that have the issue can they resolve wpad? are these clients in a GPO environment? If so Could you try pushing them the proxy settings though GPO?

    hey the users are using windows 7, 8 and 10 (x64) and they are not in gpo environment
    thank's for reply


  • But you know whats odd…If i put pfSense as HTTPS internet explorer keeps blocking the sites but not chrome or firefox soo odd..but anyway Also which computers exactly are not auto detecting? WPAD is pretty powerful and forces all client to the proxy ONLY IF the auto detect proxy settings is checked