Ständig Verbindungsabbrüche mit PPPoe Passthrough



  • Hallo zusammen,

    Unsere pfSense läuft hinter einer FritzBox mit PPPoe Passthrough. Leider funktioniert ~ alle 2 Tage die WAN Verbindung nicht. Es hilft dann meistens nur ein Neustart.

    In den Logs finde ich das:
    System > General

    Mar 23 04:00:00 check_reload_status: Configuring interface wan
    Mar 23 04:00:01 check_reload_status: Rewriting resolv.conf
    Mar 23 04:00:01 check_reload_status: Rewriting resolv.conf
    Mar 23 04:00:04 check_reload_status: Rewriting resolv.conf
    Mar 23 04:00:06 php-fpm[74589]: /rc.newwanipv6: rc.newwanipv6: Failed to update WAN[wan] IPv6, restarting…
    Mar 23 04:06:05 check_reload_status: Rewriting resolv.conf
    Mar 23 04:06:08 check_reload_status: Rewriting resolv.conf
    Mar 23 04:06:10 php-fpm[74589]: /rc.newwanipv6: rc.newwanipv6: Failed to update WAN[wan] IPv6, restarting…
    Mar 23 04:12:08 check_reload_status: Rewriting resolv.conf
    Mar 23 04:12:10 check_reload_status: Rewriting resolv.conf
    Mar 23 04:12:12 php-fpm[74589]: /rc.newwanipv6: rc.newwanipv6: Failed to update WAN[wan] IPv6, restarting…
    Mar 23 04:18:11 check_reload_status: Rewriting resolv.conf
    Mar 23 04:18:15 check_reload_status: Rewriting resolv.conf
    Mar 23 04:18:16 check_reload_status: Rewriting resolv.conf
    Mar 23 04:18:17 php-fpm[74589]: /rc.newwanipv6: rc.newwanipv6: Failed to update WAN[wan] IPv6, restarting…

    Man sieht, dass die Firewall versucht eine IPv6 Adresse zu erhalten, obwohl IPv6 auf dem Interface eigentlich deaktiviert ist.

    PPP:
    Mar 23 04:10:28 ppp: [wan] IPADDR 0.0.0.0
    Mar 23 04:10:28 ppp: [wan] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Mar 23 04:10:28 ppp: [wan] PRIDNS 0.0.0.0
    Mar 23 04:10:28 ppp: [wan] SECDNS 0.0.0.0
    Mar 23 04:10:30 ppp: [wan] IPCP: parameter negotiation failed
    Mar 23 04:10:30 ppp: [wan] IPCP: state change Ack-Sent –> Stopped
    Mar 23 04:10:30 ppp: [wan] IPCP: LayerFinish
    Mar 23 04:10:31 ppp: [wan] IPCP: rec'd Configure Request #74 (Stopped)
    Mar 23 04:10:31 ppp: [wan] IPADDR 82.XXX.XX.XX
    Mar 23 04:10:31 ppp: [wan] 82.XXX.XX.XX is OK
    Mar 23 04:10:31 ppp: [wan] IPCP: LayerStart
    Mar 23 04:10:31 ppp: [wan] IPCP: SendConfigReq #35
    Mar 23 04:10:31 ppp: [wan] IPADDR 0.0.0.0
    Mar 23 04:10:31 ppp: [wan] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Mar 23 04:10:31 ppp: [wan] PRIDNS 0.0.0.0
    Mar 23 04:10:31 ppp: [wan] SECDNS 0.0.0.0
    Mar 23 04:10:31 ppp: [wan] IPCP: SendConfigAck #74
    Mar 23 04:10:31 ppp: [wan] IPADDR 82.XXX.XX.XX
    Mar 23 04:10:31 ppp: [wan] IPCP: state change Stopped –> Ack-Sent
    Mar 23 04:10:34 ppp: [wan] IPCP: SendConfigReq #36
    Mar 23 04:10:34 ppp: [wan] IPADDR 0.0.0.0
    Mar 23 04:10:34 ppp: [wan] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Mar 23 04:10:34 ppp: [wan] PRIDNS 0.0.0.0
    Mar 23 04:10:34 ppp: [wan] SECDNS 0.0.0.0

    Wenn es dann mal funktioniert sieht es so aus:
    Mar 23 04:18:15 ppp: [wan] IPADDR 82.XXX.XX.XX
    Mar 23 04:18:15 ppp: [wan] 82.XXX.XX.XX is OK
    Mar 23 04:18:15 ppp: [wan] IPCP: SendConfigAck #1
    Mar 23 04:18:15 ppp: [wan] IPADDR 82.XXX.XX.XX
    Mar 23 04:18:15 ppp: [wan] IPCP: state change Req-Sent –> Ack-Sent
    Mar 23 04:18:15 ppp: [wan] IPCP: rec'd Configure Reject #249 (Ack-Sent)
    Mar 23 04:18:15 ppp: [wan] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Mar 23 04:18:15 ppp: [wan] IPCP: SendConfigReq #250
    Mar 23 04:18:15 ppp: [wan] IPADDR 0.0.0.0
    Mar 23 04:18:15 ppp: [wan] PRIDNS 0.0.0.0
    Mar 23 04:18:15 ppp: [wan] SECDNS 0.0.0.0
    Mar 23 04:18:15 ppp: [wan] IPV6CP: rec'd Configure Request #1 (Req-Sent)
    Mar 23 04:18:15 ppp: [wan] IPV6CP: SendConfigAck #1
    Mar 23 04:18:15 ppp: [wan] IPV6CP: state change Req-Sent –> Ack-Sent
    Mar 23 04:18:15 ppp: [wan] IPV6CP: rec'd Configure Ack #7 (Ack-Sent)
    Mar 23 04:18:15 ppp: [wan] IPV6CP: state change Ack-Sent –> Opened
    Mar 23 04:18:15 ppp: [wan] IPV6CP: LayerUp
    Mar 23 04:18:15 ppp: [wan] 0208:XXX:XXX:XXX -> 1a8b:XXX:XXX:XXX
    Mar 23 04:18:16 ppp: [wan] IFACE: Up event
    Mar 23 04:18:16 ppp: [wan] IFACE: Rename interface ng0 to pppoe0
    Mar 23 04:18:16 ppp: [wan] IPCP: rec'd Configure Nak #250 (Ack-Sent)
    Mar 23 04:18:16 ppp: [wan] IPADDR 188.XXX.X.XXX
    Mar 23 04:18:16 ppp: [wan] 188.XXX.X.XXX is OK
    Mar 23 04:18:16 ppp: [wan] PRIDNS 212.XX.X.X
    Mar 23 04:18:16 ppp: [wan] SECDNS 212.XX.X.X
    Mar 23 04:18:16 ppp: [wan] IPCP: SendConfigReq #251
    Mar 23 04:18:16 ppp: [wan] IPADDR 188.XXX.X.XXX
    Mar 23 04:18:16 ppp: [wan] PRIDNS 212.XX.X.X
    Mar 23 04:18:16 ppp: [wan] SECDNS 212.XX.X.X
    Mar 23 04:18:16 ppp: [wan] IPCP: rec'd Configure Ack #251 (Ack-Sent)
    Mar 23 04:18:16 ppp: [wan] IPADDR 188.XXX.X.XXX
    Mar 23 04:18:16 ppp: [wan] PRIDNS 212.XX.X.X
    Mar 23 04:18:16 ppp: [wan] SECDNS 212.XX.X.X
    Mar 23 04:18:16 ppp: [wan] IPCP: state change Ack-Sent –> Opened
    Mar 23 04:18:16 ppp: [wan] IPCP: LayerUp
    Mar 23 04:18:16 ppp: [wan] 188.XXX.X.XXX -> 82.XXX.XX.XX

    (IP Adressen habe ich zensiert)
    Auch hier sieht man, dass pfSense eine IPv6 Adresse abruft, obwohl IPv6, wie gesagt, eigentlich deaktiviert ist.

    Könnt ihr euch da einen Reim drauf machen?

    Grüße,
    Sven



  • Banned

    Hi!

    Unter

    System: Advanced: Networking

    ist auch kein Haken bei IPv6?

    Und bei

    System: Gateways

    ist als "Adress family" IPv4 gewählt?

    Ich hatte jahrelange Fritzboxen und jetzt ein Draytek in einem vergleichbaren Aufbau (als DSL-Modem konfiguriert) ohne Probleme mit der Pfsense beim nächtlichen re-connect…



  • @2chemlud:

    Hi!

    Unter

    System: Advanced: Networking

    ist auch kein Haken bei IPv6?

    Und bei

    System: Gateways

    ist als "Adress family" IPv4 gewählt?

    Ich hatte jahrelange Fritzboxen und jetzt ein Draytek in einem vergleichbaren Aufbau (als DSL-Modem konfiguriert) ohne Probleme mit der Pfsense beim nächtlichen re-connect…

    Hi,

    ja, bei beiden Einstellungen ist IPv4 gewählt > Siehe Anhang

    Ich kann mir das auch alles nicht erklären - ich stehe nun schon lange in Kontakt mit dem Support meines Resellers, der sich auch große Mühe gegeben hat aber leider vergeblich..





  • Banned

    Mach mal den "prefer to use IPv4 even if  IPv6 is available" Haken raus



  • @2chemlud:

    Mach mal den "prefer to use IPv4 even if  IPv6 is available" Haken raus

    Tatsächlich habe ich den heute in der früh nach dem erneuten Disconnect erst hinzugefügt.. Ich würde da gerne erst mal die Resultate beobachten.


Log in to reply