2.3-RC and HAProxy



  • Hi all,

    Just wondered if anyone else had experienced any issues with 2.3-RC (latest build) and HAProxy? I updated one of our machines here that had HAProxy installed but not in use and I kept getting the "programming error was detected message". It wasn't a big deal as I just uninstalling and then re-installing but still getting the same issue.

    No big deal at this moment in time but I do want to update another machine I have that does depend on HAProxy and want to make sure it was just a problem with that install.

    Anyone else had any issues?


  • Rebel Alliance Developer Netgate

    I have it on a VM here that I test with but I don't recall seeing any errors.

    What is the specific content of the error message?



  • I'm using 2.3 with haproxy for a few weeks now on a full x64 install. What are you running it on?

    Exact error message shown would be interesting indeed. I'm also wondering if perhaps a old haproxy file from before upgrading is making trouble.. Does the package 'work' for you or are pages having trouble showing & saving?



  • I tried updating from 2.2.6 to 2.3-RC and HA Proxy didn't work at all.
    Some message about a php carp function - which I think may have been deprecated in 2.3.
    Possibly there were some libraries that weren't uninstalled/reinstalled correctly
    I did attempt to use squid reverse proxy instead, but that either doesn't work or is too bizarre to configure - either way squid seems not worth the effort. It was unstable on 2.2.6 anyway.

    The error I'm getting on install is:
    Executing custom_php_install_command()…PHP ERROR: Type: 1, File: /usr/local/pkg/haproxy_utils.inc, Line: 165, Message: Call to undefined function get_configured_ip_aliases_list()pkg: POST-INSTALL script failed

    I fixed this by:

    1. removing haproxy (via gui)
    2. cd'ing into /usr/local/pkg and doing rm haproxy*.inc
    3. reinstalling haproxy

    All seems well, it's kept all my settings - so happy as Larry again ;-)



  • Thanks for the replies.

    I've attached the error of the log, I can confirm I have just received the same issue on another completely different network and machine. However using the suggestions above from deadmalc worked perfectly for me also!




  • I'm now getting this error appearing:
    PHP Errors:
    [01-Apr-2016 23:00:00 Europe/London] PHP Stack trace:
    [01-Apr-2016 23:00:00 Europe/London] PHP  1. {main}() /etc/rc.haproxy_ocsp.sh:0
    [01-Apr-2016 23:00:00 Europe/London] PHP Fatal error:  require_once(): Failed opening required 'haproxy.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form')

    HAProxy seems fine, so maybe there is something else left over that wasn't removed.

    I had to update /etc/rc.haproxy_ocsp.sh to point at the correct include places:

    #!/usr/local/bin/php-cgi -f

    /*
            Updates haproxy OCSP responses.
    */

    require_once("globals.inc");
    require_once("functions.inc");
    require_once("haproxy/haproxy.inc");
    require_once("haproxy/haproxy_socketinfo.inc");
    haproxy_updateocsp();

    ?>



  • Ah thanks thats one that was fixed in haproxy-devel, sending pullrequest for haproxy now..


Log in to reply