Połączenie z webgui



  • Witam, poszukuje rozwiązania problemu połączenia z webgui. Wczoraj zmieniłem port na 80 i od tego momentu nie mam połączenia z webgui przez https

    Rzeczy które już wykonałem:

    • z pliku /conf/config.xml wyrzuciłem port z sekcji webgui
    • Przywróciłem z konsoli konfigurację z dnia wczorajszego
    • zmieniłem adres ip serwera przez konsole i pojawia mi się komunikat, że jak chce się połączyć wystaczy, że wpiszę w przeglądarkę adres http://192.xxx.xxx.xxx/

    połączenia nadal brak.

    Sprawdziłem nmapem i mam pozamykane wszystkie porty, ale połączenie z internetem jest.

    Zna ktoś rozwiązanie takiego problemu?
    dodatkowo: jak mogę otworzyć porty przez ssh?



  • Hej,
    Tutaj masz czesc informacji, byc moze cos Ci pomoze:

    https://doc.pfsense.org/index.php/Locked_out_of_the_WebGUI

    Jesli chodzi o dodanie regulek FW z poziomu ssh to uzywasz polecenia: easyrule

    : easyrule
    usage:
    Blocking only requires an IP to block
        easyrule block <interface> <source ip="">
    
    Passing requires more detail, as it must be as specific as possible. The destination port is
    optional if you're using a protocol without a port (e.g. ICMP, OSPF, etc).
        easyrule pass <interface> <protocol> <source ip=""> <destination ip=""> [destination port]
    
    Block example:
        easyrule block wan 1.2.3.4
    
    Pass example (protocol with port):
        easyrule pass wan tcp 1.2.3.4 192.168.0.4 80
    
    Pass example (protocol without port):
        easyrule pass wan icmp 1.2.3.4 192.168.0.4</destination></protocol></interface></interface>
    


  • Po takich zmianach zrestartuj pfsense. Czasem nie załapuje zmian które zostaną dokonane z konsoli.