Captive Portal problem at Hyper-v



  • Hi! Can somebody help me with Captive Portal problem at Hyper-v?
    I've installed 2.2.6 pfSense at Windows 2012 r2 Hyper-v (generation 1, Legacy network) and make NAT-rules. Everything work fine, but when I enabling Captive Portal I have some problems. After entering a voucher (or username\password) in browser it redirects at the same page! But computer has access to the Internet (I try ping or telnet Internet resources). Internet is not  appears only in the browser!
    The same configuration of pfSense works great at vmware at the same server.



  • At a guess, I'd say you have a DNS problem. But without knowing your exact settings it's impossible to tell.



  • no, dns fine, because command like "telnet www.yahoo.com 443" - is good, after intering the voucher.



  • Well then obviously I haven't understood your question. Perhaps if you rephrase it? What exactly is wrong? Are you saying you can't access the internet or that you can even when the captive portal is activated? I realise English probably isn't your native language, but you'll have to clarify what the precise issue is clearly before you can expect anyone to help.



  • Sorry for my English :)
    I make clear installation of pfSense (virtual machine) at my Hyper-v server.
    I've set up IP addresses (WAN/LAN), NAT-rules and checked internet from user's computer. Everything fine.
    Then I've activated captive portal with Vouchers authentication (Portal page is default).
    Before a vaucher usage, any internet access tries from users's pc, like "telnet yahoo.com  443" or "ping 8.8.4.4" were unsuccessful, and Internet Explorer was redirected to portal page.

    When I use the vaucher, pfSense accepts it (I see it at Status - Captive portal - Active Vouchers) and commands telnet and ping return successfull results.
    But Internet Explorer still redirects me to the portal page every time tried to go anywhere.

    If I do all the same at the esxi server as a virtualization host (the same physical server), the Internet explorer works fine.



  • Do you have a proxy server set in your browser settings? If you're able to resolve internet addresses but your browser takes you to the login page only, it sounds like your browser is configured to use a proxy or forwarder.



  • No, I don't use proxy.
    Also I have tried from different users computers and different browsers (chrome, firefox).



  • In which case the issue must be due to some misconfiguration in your Hyper-V environment. If the same setup works find in a VMWare environment as you say, then Hyper-V must be the source of the issue.



  • Yes, I understand that. But what could be the reason? I've tried use legacy network, maybe I should try something else?



  • I'm no Hyper-V expert, but I'd perhaps have a look at the routing/DNS settings on your Hyper-V server. Also, check to see if you have any specific firewall settings on your H-V server which might be causing the issue. Not sure what you mean by 'legacy network' in Hyper-V context, but if you think it might work then give it a go.



  • The virtual machine does not use dns or routing of host machine.
    And everything works fine when the captive portal is disabled…
    I'd like to find someone who has the same configuration (pfsense + captive portal and vouchers) in Hyper-V environment and it's working fine and correct.