Issues updating from 2.3-RC (or older 2.3 installs) to 2.3-RELEASE


  • Rebel Alliance Developer Netgate

    For issues updating from RC (or older) to -RELEASE:


    No trusted public keys found
    If you see an error when checking for or installing updates that states “No trusted public keys found”, run the following command from the shell or Diagnostics > Command:

    fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406
    

    Unable to Check for Updates
    If you see “unable to check for updates”, and/or the package manager cannot fetch data:

    First, make sure you have pfSense-base or pfSense-base-nanobsd installed:

    Check the output of:

    pkg info -x pfSense
    

    If pfSense-base is missing (Full install) or if pfSense-base-nanobsd missing (NanoBSD), run:

    pkg install pfSense-base
    

    Upgrade resulted in running 2.3.1 or the version claims to be newer

    For anyone who landed on 2.3.1 or has a message stating that they are on a newer version than release: To get 2.3-RELEASE proper, follow this:

    First, check the pkg repository configuration:

    ls -l /usr/local/etc/pkg/repos/pfSense.conf
    

    It should point to /usr/local/share/pfSense/pkg/repos/pfSense-repo.conf

    If it does not:

    rm /usr/local/etc/pkg/repos/pfSense.conf
    ln -s /usr/local/share/pfSense/pkg/repos/pfSense-repo.conf /usr/local/etc/pkg/repos/pfSense.conf
    

    Double check the contents of the file:

    : cat /usr/local/etc/pkg/repos/pfSense.conf 
    FreeBSD: { enabled: no }
    
    pfSense-core: {
      url: "pkg+http://pkg.pfsense.org/pfSense_v2_3_0_amd64-core",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    
    pfSense: {
      url: "pkg+http://pkg.pfsense.org/pfSense_v2_3_0_amd64-pfSense_v2_3_0",
      mirror_type: "srv",
      signature_type: "fingerprints",
      fingerprints: "/usr/local/share/pfSense/keys/pkg",
      enabled: yes
    }
    

    If the contents of that file matches above, OK, if not, edit the file and make it match.

    Force an update to the pkg database:

    pkg update -f
    

    If that fails:

    fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406
    

    And then run the update command again.

    Lastly, force an upgrade of all installed packages:

    pkg upgrade -f
    

    If an error is shown that the kernel package is locked, you can unlock it with “pkg unlock <name>” replacing <name>with what the error complains about, then run the “pkg update -f” command again. Be sure to lock it back after you’re done.</name></name>



  • One bug I’m getting, I did that and was able to upgrade to 2.3-Release.
    On the dashboard page it shows 2.3-RELEASE (amd64)  The system is on a later version than the official release.
    It doesn’t show the update available button, but when I go to the System > Update it shows,
    Current Base System 2.3.1.a.20160412.1112
    Latest Base System 2.3
    and has the update button, I click it but get,
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Your packages are up to date
    Success

    So I guess it’s just reading the current base system incorrectly? No biggie just throwing that out there.



  • I’m seeing:

    Current Base System 2.3.r.20160406.0534
      Latest Base System 2.3.1.a.20160412.1222

    even though I have Update Settings set to

    Follow 2.3 snapshots and move automatically to -RELEASE (Default). The Dashboard still shows that I’m on 2.3-RC.


  • Rebel Alliance Developer Netgate

    @ohwell:

    I’m seeing:

    Current Base System 2.3.r.20160406.0534
      Latest Base System 2.3.1.a.20160412.1222

    even though I have Update Settings set to

    Follow 2.3 snapshots and move automatically to -RELEASE (Default). The Dashboard still shows that I’m on 2.3-RC.

    To make sure you’re on the right track, click Save on the update settings with that set. Then run the update. It will show that and then during the backup it will see -RELEASE and use that instead, due to that setting.



  • @jimp:

    To make sure you’re on the right track, click Save on the update settings with that set. Then run the update. It will show that and then during the backup it will see -RELEASE and use that instead, due to that setting.

    I saved as Dev, then saved as Stable.

    Still showed 2.3.1 (noting what you said above), and hit update:

    
    >>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    ERROR: It was not possible to determine pfSense-repo-devel remote version
    Failed
    
    


  • @Achromatic:

    @jimp:

    To make sure you’re on the right track, click Save on the update settings with that set. Then run the update. It will show that and then during the backup it will see -RELEASE and use that instead, due to that setting.

    I saved as Dev, then saved as Stable.

    Still showed 2.3.1 (noting what you said above), and hit update:

    
    >>> Updating repositories metadata... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    ERROR: It was not possible to determine pfSense-repo-devel remote version
    Failed
    
    

    I was on the last RC before release and was on the stable track but saw update to 2.3.1a. Saving RELEASE track in settings didn’t show 2.3. SSH’d in and downloaded new pkg key but still showed 2.3.1a. Solved it by selecting “13) Update from console” which removed the old repo-devel, refreshed the pkg database and offered update to 2.3 which worked great.



  • Mine is showing the same thing.

    @qubit:

    I was on the last RC before release and was on the stable track but saw update to 2.3.1a. Saving RELEASE track in settings didn’t show 2.3. SSH’d in and downloaded new pkg key but still showed 2.3.1a. Solved it by selecting “13) Update from console” which removed the old repo-devel, refreshed the pkg database and offered update to 2.3 which worked great.

    That fixed it!  Thanks!!



  • I ended up doing a clean install of 2.3 release after it upgraded me to 2.3.1 from RC.



  • I’ve tried the suggestions in this thread but they’ve made no difference. Every time I try initiating the update I get stuck at

    >>> Updating repositories metadata...
    Updating FreeBSD repository catalogue...
    FreeBSD repository is up-to-date.
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    >>> Upgrading pkg...
    

    EDIT: On another box I had the options Development and Stable in the Update Settings and on that box, after updating the keys, the update went smoothly. I think part of the problem might be that the box I’m having trouble on has an older version because the Update Settings page does not have those exact options.

    2ND EDIT: Grrr. Tried getting around this by changing the Branch setting from Follow 2.3 snapshots and move automatically to -RELEASE to Keep following 2.3 development snapshots in the Update Settings. My thinking was this would bring me up to date up to the latest 2.3 RC version and then I’d be good to go on updating to RELEASE. Well, ended on up 2.3.1-DEVELOPMENT and now I’m getting The system is on a later version than the official release. This is solved for me: I’m taking the easy way out and restoring from a earlier snapshot that had 2.2.6 and updating from there.



  • Well, any way to come back from 2.3.1-dev to 2.3 Release without a reinstall ?



  • Hi

    I found out, that I’m still on

    pfSense-repo-2.3.r.20160406.0534

    but can not upgrade to pfSense-repo-2.3.1.a.20160412.1222

    pkg version
    
    pfSense-rc-2.3.1.a.20160412.1222   =
    pfSense-repo-2.3.r.20160406.0534   <
    
    pkg search pfSense-repo
    pfSense-repo-2.3.1.a.20160412.1222 pfSense pkg repository configuration (stable)
    
    pkg install pfSense-repo-2.3.1.a.20160412.1222
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    pkg: No packages available to install matching 'pfSense-repo-2.3.1.a.20160412.1222' have been found in the repositories
    


  • I have two pfSense appliances. Both on Version 2.3.r.20160405.0247.
    On one pfSense it worked after I used```
    fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406

    
    On the other pfSense I still get 2.3.1.a.20160412.1222 from the update tab. Changed the firmware branch to development and back to stable. Does not seem to work, when I select development it refreshes and jumps back to stable. Tried using option 13 on cli but still get 2.3.1.a.20160412.1222.
    
    Any suggestions?


  • One of my pfSense boxes is already 2.3.1a
    The other one, after having set Stable in update settings, wants to update to 2.3.1a regardless of trying in GUI or Shell

    pfSense-base: 2.3.r.20160331.2348 -> 2.3.1.a.20160412.1222 [pfSense-core]
    


  • I am also having an issue with updating. I was on the last RC and attempted to update to 2.3-RELEASE and received the following error.



  • @jimp:

    @ohwell:

    I’m seeing:

    Current Base System 2.3.r.20160406.0534
      Latest Base System 2.3.1.a.20160412.1222

    even though I have Update Settings set to

    Follow 2.3 snapshots and move automatically to -RELEASE (Default). The Dashboard still shows that I’m on 2.3-RC.

    To make sure you’re on the right track, click Save on the update settings with that set. Then run the update. It will show that and then during the backup it will see -RELEASE and use that instead, due to that setting.

    You guys made a major poop on this one.
    By following this some of us some how ended up on the dev even though we had the “Follow 2.3 snapshots and move automatically to -RELEASE (Default)” set.
    How can we fix this? Like others here I try to force an update to 2.3-RELEASE but I cant cause I am on a devel version.
    There has to be a fix to this without having to re-install.



  • @raidflex:

    I am also having an issue with updating. I was on the last RC and attempted to update to 2.3-RELEASE and received the following error.

    First post of jimp resolves this issue !


  • Rebel Alliance Developer Netgate

    @serialdie:

    You guys made a major poop on this one.

    I don’t  know about that, at this point 2.3.1 is ~= 2.3-REL (aside from a few extra fixes, so, bonus). It didn’t brick anything, things still work, etc. Inconvenient, sure, but not FUBAR.

    @serialdie:

    By following this some of us some how ended up on the dev even though we had the “Follow 2.3 snapshots and move automatically to -RELEASE (Default)” set.
    How can we fix this? Like others here I try to force an update to 2.3-RELEASE but I cant cause I am on a devel version.
    There has to be a fix to this without having to re-install.

    There is, I was able to replicate it once yesterday. I’m working on a procedure to switch back. It’s not terribly difficult, but I need to be able to repeat it reliably.



  • @deajan:

    @raidflex:

    I am also having an issue with updating. I was on the last RC and attempted to update to 2.3-RELEASE and received the following error.

    First post of jimp resolves this issue !

    I was also successful with updating using the command in the first post.  Thanks for the fix!



  • Please, help me to restore a full back-up that i made before “upgrading” to 2.3. My snort rules doesn’t work anymore and i have the feeling that a bunch of other things are broken now with this new 2.3 release.

    I have the back-up stored on /root  ( pfSense-full-backup-20160413-1446.tgz). How can i invoke it from the terminal?  In /etc i can’t find any rc.restore full back-up. On the forum i can’t find any other info about this.  Thank you in advance.


  • Rebel Alliance Developer Netgate

    @waves:

    Please, help me to restore a full back-up that i made before “upgrading” to 2.3. My snort rules doesn’t work anymore and i have the feeling that a bunch of other things are broken now with this new 2.3 release.

    I have the back-up stored on /root  ( pfSense-full-backup-20160413-1446.tgz). How can i invoke it from the terminal?  In /etc i can’t find any rc.restore full back-up. On the forum i can’t find any other info about this.  Thank you in advance.

    That feature is not supported on pfSense 2.3. Your safest path is to reinstall the older version directly. Otherwise you’ll end up with a mix of things all over the filesystem (which was one of many reasons that feature was removed…)

    Better still would be to work and get snort working on 2.3. The package maintainer is very active in the IDS/IPS board here under packages. Post there for snort help, it’s probably not a difficult fix.



  • @jimp:

    @serialdie:

    You guys made a major poop on this one.

    I don’t  know about that, at this point 2.3.1 is ~= 2.3-REL (aside from a few extra fixes, so, bonus). It didn’t brick anything, things still work, etc. Inconvenient, sure, but not FUBAR.

    @serialdie:

    By following this some of us some how ended up on the dev even though we had the “Follow 2.3 snapshots and move automatically to -RELEASE (Default)” set.
    How can we fix this? Like others here I try to force an update to 2.3-RELEASE but I cant cause I am on a devel version.
    There has to be a fix to this without having to re-install.

    There is, I was able to replicate it once yesterday. I’m working on a procedure to switch back. It’s not terribly difficult, but I need to be able to repeat it reliably.

    Thank you for your fast reply jimp.


  • Rebel Alliance Developer Netgate

    I just edited a fix into the first post for people who ended up on 2.3.1 or otherwise have a message saying they’re on a version newer than the release. Should fix it all up.



  • That feature is not supported on pfSense 2.3. Your safest path is to reinstall the older version directly. Otherwise you’ll end up with a mix of things all over the filesystem (which was one of many reasons that feature was removed…)

    Better still would be to work and get snort working on 2.3. The package maintainer is very active in the IDS/IPS board here under packages. Post there for snort help, it’s probably not a difficult fix.

    This is very bad news…  😞  I will try to install the older version and restore config.xml.  I have a post in IDS as well, but i’m in a production enviroment and…  You get my point.  Thank you for your reply.



  • @waves:

    That feature is not supported on pfSense 2.3. Your safest path is to reinstall the older version directly. Otherwise you’ll end up with a mix of things all over the filesystem (which was one of many reasons that feature was removed…)

    Better still would be to work and get snort working on 2.3. The package maintainer is very active in the IDS/IPS board here under packages. Post there for snort help, it’s probably not a difficult fix.

    This is very bad news…  😞  I will try to install the older version and restore config.xml.  I have a post in IDS as well, but i’m in a production enviroment and…  You get my point.  Thank you for your reply.

    Ouch!
    2.3 is too new for production, Hence why I am using it at home/dev for now. Good luck.



  • @jimp,

    Thanks for the update… so far so good.



  • Hello,

    after update I’ve many problems and web gui shows always this message :

    pfSense is booting, then packages will be reinstalled in the background.
    Do not make changes in the GUI until this is complete.
    

    I’ve tried the Jimp’s guide at first post but it doesn’t work :

    
    pkg update -f
    fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406
    fetch: https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406: Network is unreachable
    

    Any help is very appreciated .
    Best regards



  • have done everything is post #1 am still stuck….

    2.3-RELEASE (amd64)
    built on Mon Apr 11 18:10:34 CDT 2016
    FreeBSD 10.3-RELEASE
    
    The system is on a later version than
    the official release.
    

    Myk



  • fetch -qo /usr/local/share/pfSense/keys/pkg/trusted/ https://raw.githubusercontent.com/pfsense/pfsense/RELENG_2_3_0/src/usr/local/share/pfSense/keys/pkg/trusted/pkg.pfsense.org.20160406
    
    

    … worked for me. Thanks!



  • @jimp:

    I just edited a fix into the first post for people who ended up on 2.3.1 or otherwise have a message saying they’re on a version newer than the release. Should fix it all up.

    worked for me. you da man!!!



  • My pfsense box cant access the internet unless it is using a proxy (the proxy is separate to this instance of pfsense). It managed to update but now it is stuck attempting to download package metadata 😞




  • @YonNomNom:

    My pfsense box cant access the internet unless it is using a proxy (the proxy is separate to this instance of pfsense). It managed to update but now it is stuck attempting to download package metadata 😞

    Oh yes,

    my problem is the same…. So now I know because I can’t update my catalogue…
    But how fix this issue ??

    EDIT

    Fixed…. After the upgrade to the new version no default gateway was selected by pfsense… So no route to Internet…

    System_Routing_Gateways_Edit
    Select This will select the above gateway as the default gateway
    

    Super Regards


  • Rebel Alliance Developer Netgate

    @christian.arminio:

    after update I’ve many problems and web gui shows always this message :

    pfSense is booting, then packages will be reinstalled in the background.
    Do not make changes in the GUI until this is complete.
    

    I’ve tried the Jimp’s guide at first post but it doesn’t work :

    Diag > Backup/Restore, click the button to reset the package lock.


  • Rebel Alliance Developer Netgate

    For those with other unrelated issues like proxies/gateways, please start new threads. This thread is only for the specific style of issues stated in the original post, thanks.



  • @wirerogue:

    @jimp:

    I just edited a fix into the first post for people who ended up on 2.3.1 or otherwise have a message saying they’re on a version newer than the release. Should fix it all up.

    worked for me. you da man!!!

    Worked for me too…



  • @marjohh:

    @wirerogue:

    @jimp:

    I just edited a fix into the first post for people who ended up on 2.3.1 or otherwise have a message saying they’re on a version newer than the release. Should fix it all up.

    worked for me. you da man!!!

    Worked for me too…

    Worked for me as well…  THANK YOU!



  • Hi all,

    Just quick question… where if ntopng package gone? I cant see it in ‘Available packages’ tab. I did use it a lot and now I am stuck 😕



  • @fr0t:

    Hi all,

    Just quick question… where if ntopng package gone? I cant see it in ‘Available packages’ tab. I did use it a lot and now I am stuck 😕

    https://doc.pfsense.org/index.php/2.3_Removed_Packages



  • pfSense is booting, then packages will be reinstalled in the background.
    Do not make changes in the GUI until this is complete.
    

    I had this problem a while back with my nano system at home earlier this year.  I’d suggest looking through your config.xml file and see it there are any duplicate sections, mine had two sections setting up the local DHCP server on different subnets and once I deleted the bad one everything worked fine.



  • I was on 2.3.1.xxxx and noticed this morning it was unable to check for updates and the packages section shows no packages installed. I went to diagnostics/command prompt and tried pkg upgrade -f and got:

    Updating pfSense-core repository catalogue…
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue…
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    New version of pkg detected; it needs to be installed first.
    The following 1 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
    pkg: 1.7.2 -> 1.7.2_1 [pfSense]

    2 MiB to be downloaded.

    Proceed with this action? [y/N]:

    How does one and the y/N question??? Is this even the answer to my problem?


  • Rebel Alliance Developer Netgate

    @brianc69:

    I was on 2.3.1.xxxx and noticed this morning it was unable to check for updates and the packages section shows no packages installed. I went to diagnostics/command prompt and tried pkg upgrade -f and got:

    Updating pfSense-core repository catalogue…
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue…
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    New version of pkg detected; it needs to be installed first.
    The following 1 package(s) will be affected (of 0 checked):

    Installed packages to be UPGRADED:
    pkg: 1.7.2 -> 1.7.2_1 [pfSense]

    2 MiB to be downloaded.

    Proceed with this action? [y/N]:

    How does one and the y/N question??? Is this even the answer to my problem?

    ‘y’ is OK there. But please read the original post of the thread, second section, last entry.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy