Gateways showing down after upgrade from 2.2 to 2.3 release



  • Hi, my gateway monitoring on my pfsense homepage shows offline after upgrading from 2.2 to 2.3 release. They worked fine before the upgrade.



  • Ok
    I have attached an image to better show my issue.
    The monitor IP's have not changed, however, when i do edit them and hit save, the Gateways show online for a few seconds then back to offline
    My internet is still working fine but i wish to have my gateways monitoring show what they used to




  • They are also setup as a group…..not sure if thats an issue but never was.
    ill play around some more until i get a reply or something



  • Home page screen shot




  • What logs do you have from dpinger in your gateways log?



  • This is what i saw

    Apr 12 16:22:06 dpinger send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr x.x.160.202 bind_addr x.x.160.202 identifier "GW_WAN "

    Apr 12 16:22:06 dpinger send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 192.168.1.254 bind_addr 192.168.1.89 identifier "ADSLGW "

    Apr 12 16:22:06 dpinger GW_WAN x.x.160.202: sendto error: 65
    Apr 12 16:22:06 dpinger ADSLGW 192.168.1.254: sendto error: 65
    Apr 12 16:22:07 dpinger GW_WAN x.x.160.202: sendto error: 65
    Apr 12 16:22:07 dpinger ADSLGW 192.168.1.254: sendto error: 65
    Apr 12 16:22:07 dpinger ADSLGW 192.168.1.254: sendto error: 65
    Apr 12 16:22:07 dpinger GW_WAN x.x.160.202: sendto error: 65
    Apr 12 16:22:08 dpinger GW_WAN x.x.160.202: sendto error: 65

    Apr 12 16:22:09 dpinger ADSLGW 192.168.1.254: Alarm latency 0us stddev 0us loss 100%
    Apr 12 16:22:09 dpinger GW_WAN x.x.160.202: Alarm latency 0us stddev 0us loss 100%

    Apr 12 17:51:18 dpinger send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr x.x160.202 bind_addr x.x.160.202 identifier "GW_WAN "

    Apr 12 17:51:18 dpinger send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 192.168.1.254 bind_addr 192.168.1.89 identifier "ADSLGW "



  • Hm, nothing apparent from that. Mind getting me into the system? Can allow 208.123.73.0/24 WAN-side, and PM me here with access info. Or /msg cmb on Freenode if you're on IRC and we can arrange.



  • I'm having the same issue! Looks like I'll have to do a fresh install and hope it fixes the dpinger gateway issue!  :(

    I'm also having cpu spikes, that I never had with 2.2.6?



  • If dpinger isn't running, it's almost certainly because you had advanced monitoring options defined that are now invalid. Go to System>Routing, edit your gateway, and click Save. That'll trigger the input validation showing what's wrong. Reinstall is not going to fix that, it's something in your config.

    If you have a config that didn't work post-upgrade, I'd like to know exactly what was in there for gateway monitoring. I'd like to add config upgrade code to the next release so it fixes invalid configs.



  • @cmb:

    If dpinger isn't running, it's almost certainly because you had advanced monitoring options defined that are now invalid. Go to System>Routing, edit your gateway, and click Save. That'll trigger the input validation showing what's wrong. Reinstall is not going to fix that, it's something in your config.

    If you have a config that didn't work post-upgrade, I'd like to know exactly what was in there for gateway monitoring. I'd like to add config upgrade code to the next release so it fixes invalid configs.

    I did a fresh install and had the same problem… however did what you mentioned I had to input the internal IP into the MONITOR IP section and wah-la it works! Thanks for the info, I appreciate what you're doing kind sir, you are a gentleman & a scholar!

    Cheers!



  • @cmb:

    If dpinger isn't running, it's almost certainly because you had advanced monitoring options defined that are now invalid. Go to System>Routing, edit your gateway, and click Save. That'll trigger the input validation showing what's wrong. Reinstall is not going to fix that, it's something in your config.

    If you have a config that didn't work post-upgrade, I'd like to know exactly what was in there for gateway monitoring. I'd like to add config upgrade code to the next release so it fixes invalid configs.

    This does not work for me so i hope there is a fix in the code with the next release



  • @waynemariette:

    @cmb:

    If dpinger isn't running, it's almost certainly because you had advanced monitoring options defined that are now invalid. Go to System>Routing, edit your gateway, and click Save. That'll trigger the input validation showing what's wrong. Reinstall is not going to fix that, it's something in your config.

    If you have a config that didn't work post-upgrade, I'd like to know exactly what was in there for gateway monitoring. I'd like to add config upgrade code to the next release so it fixes invalid configs.

    This does not work for me so i hope there is a fix in the code with the next release

    Worked for me - even gave exact instructions on how to fix in a pretty pink box… For what it is worth my 'loss_interval' was a stupid high number, while the 'time_period' was much less at the default 60000ms. Was not this way pre-update if memory serves me (unfortunately it normally doesn't) ;-s

    Cheers for the solution cmb!



  • @waynemariette:

    This does not work for me so i hope there is a fix in the code with the next release

    Can't fix something that has no apparent breakage. See my last post in reply to you.



  • good afternoon,

    I am Brazilian, also I did the update 2.2.6 to 2.3 and also I have a accesses the Internet without connection on my firewall.

    Iso occurred after the upgrade, already tested this link that shows offline, and is working normally. I changed up the network card machine I use the firewall, and still can not solve this problem.

    could help?



  • @cmb:

    @waynemariette:

    This does not work for me so i hope there is a fix in the code with the next release

    Can't fix something that has no apparent breakage. See my last post in reply to you.

    yeah i sent a pm with the info



  • I added an issue in redmine https://redmine.pfsense.org/issues/6142
    I can have a look at it today.



  • @waynemariette:

    yeah i sent a pm with the info

    Thanks, I missed that. Yours is fixed. You had two issues, neither of them in pfSense. One, your monitor IP was set to your WAN IP, you need that set to something other than the system's own IP. I set it to 8.8.8.8. Maybe that was different before and you changed it around trying things. Two, your modem (or something upstream of that WAN NIC) drops ICMP packets with no data payload. That's a bug in the NAT on whatever that 192.168.1.254 device is, but we have a data payload config option to work around such problems. I set that to 1 instead of the default 0, and then it started getting replies. You're in good shape now.



  • Has solved the problem of my internet access backup that was as unavailable to available. Marked the gateway monitoring option to off and ran on time. Probably this is a problem caused in the update.






  • @cmb:

    Two, your modem (or something upstream of that WAN NIC) drops ICMP packets with no data payload. That's a bug in the NAT on whatever that 192.168.1.254 device is, but we have a data payload config option to work around such problems. I set that to 1 instead of the default 0, and then it started getting replies. You're in good shape now.

    Cheers! - Fixed the issue for me on 6 different pfsense users - all using VM in Modem Mode. It appears Virgin Media UK customers need to set a payload to 1 to fix the issue (or use another IP) or else the gateway just drops the packet! - all my other customers on non-VM connections had no issue.



  • Can someone please outline the solution to this issue? I've tried changing the monitor IP on my WAN gateway in the routing menu on the system tab to an OPENDNS IP and it still isn't fixed.

    dpinger

    send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 1000ms latency_alarm 500ms loss_alarm 20% dest_addr 208* bind_addr 97* identifier "WAN_DHCP "

    I took out the IP addresses above.

    Thanks.



  • @PF64:

    Can someone please outline the solution to this issue?

    here:
    https://forum.pfsense.org/index.php?topic=110043.0



  • Hi,

    I think I have the same bug here.
    I have 2 gateways. One of those is ok. But the another, simply show "Disconnected"

    If I ping throught the gateway "with problems" by de Status/Ping command, there are no problems.

    Apr 18 18:02:48 dpinger UNFQ_DHCP 8.8.8.8: Alarm latency 0us stddev 0us loss 100%
    Apr 18 18:02:40 dpinger send_interval 5000ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 8000ms latency_alarm 500ms loss_alarm 20% dest_addr 8.8.8.8 bind_addr 192.168.2.100 identifier "UNFQ_DHCP "
    Apr 18 18:02:40 dpinger send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 5000ms latency_alarm 500ms loss_alarm 20% dest_addr 8.8.4.4 bind_addr 192.168.1.2 identifier "BRT_DHCP "

    what is wrog?



  • same problem here.

    One gateway is ok, the other one shows "disconnected":

    
    Apr 18 18:02:48 	dpinger 		UNFQ_DHCP 8.8.8.8: Alarm latency 0us stddev 0us loss 100%
    Apr 18 18:02:40 	dpinger 		send_interval 5000ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 8000ms latency_alarm 500ms loss_alarm 20% dest_addr 8.8.8.8 bind_addr 192.168.2.100 identifier "UNFQ_DHCP "
    Apr 18 18:02:40 	dpinger 		send_interval 500ms loss_interval 2000ms time_period 60000ms report_interval 0ms data_len 0 alert_interval 5000ms latency_alarm 500ms loss_alarm 20% dest_addr 8.8.4.4 bind_addr 192.168.1.2 identifier "BRT_DHCP " 
    
    

    if I ping, everything is ok:

    
    PING 8.8.8.8 (8.8.8.8) from 192.168.2.100: 56 data bytes
    64 bytes from 8.8.8.8: icmp_seq=0 ttl=54 time=11.371 ms
    64 bytes from 8.8.8.8: icmp_seq=1 ttl=54 time=11.322 ms
    64 bytes from 8.8.8.8: icmp_seq=2 ttl=54 time=11.649 ms
    --- 8.8.8.8 ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 11.322/11.447/11.649/0.144 ms
    
    

    what is wrong??



  • @sapelli:

    I think I have the same bug here.

    not a bug (in our code), read here:
    https://forum.pfsense.org/index.php?topic=110043.0

    @sapelli:

    what is wrong??

    read here:
    https://forum.pfsense.org/index.php?topic=110043.0



  • I have exacly same issue. Tried a lot but still no internet. Are there any solution for this?



  • @Modesty:

    I have exacly same issue. Tried a lot but still no internet. Are there any solution for this?

    You probably want to start a new thread with a complete description of the problem you are experiencing. This thread referred to a (long resolved) issue with migrating monitoring parameters from apinger to dpinger which affected monitoring only.


Log in to reply