2.3 wireless breakdown



  • hello everyone let me start by saying thanks to all at pfsense software is great.

    i recently made a pfsense machine and have a  wan on 192.168.0.6/24 gets data from ADSL pppoa router
                                                                                LAN on 192.168.1.1/24 this is dhcp with arp for network
    i was running 2.2.3 when i also installed a        wireless card on 10.0.0.2/24 dhcp with arp for network

    all was running fine i can access internet via mobile and laptop over wireless and LAN was fine i even have a VPN assigned to separate IP addresses also fine .

    ( but last night i updated to 2.3 and my wireless card stalls my router as soon as i enable it in interface and when i power cycle the device it just hangs stating ( configuring wireless device).

    do I need to downgrade to 2.2.3?.  cant fine anything online to resolve this any help would be appreciated thank you.

    wireless card is TL-WN951N  from tp-link.



  • Which chip is TL-WN951N? Does it work in FreeBSD 10.3?



  • thanks for the reply, I had it working on 2.2.3 its FreeBSD10.1 it worked fine on this so assume it is supported.  has there been changes in FreeBSD10.3

    I figured I should upgrade to latest version perhaps i should wait?

    I noted in the interface tab there is an option for wireless now I will test tonight if I can initiate it there, and see if it stalls my system.  cant check at moment as people use internet during day.

    but thanks for response these forums for a none professional are very helpful managed to go without asking question till now sigh.

    chip is Atheros AR5008-3NG



  • My Atheros 9280 performance has regressed since 2.2.6 but it's OK for web surfing. Large transfers stall but I haven't had any complete hangs.

    2.2.x has wifi code from old 11-CURRENT while 2.3 has FreeBSD 10.3 code because current 11-CURRENT broke it.

    You can try your card in FreeBSD 10.3 to see if the problem is with pfSense.



  • thanks again, but as I need this wireless function I have simply reverted back to pfsense 2.2.6 FreeBSD version 10.1

    and with my regular backups everything again is perfect all working nicely.

    a small note of interest to anyone if you reformat your drive to start fresh and you have a VPN you will need to remake the file in whatever directory you had it and impute username password.

    I had more issues with 2.3 as well so it was rather unsuitable for my needs squid stopped working also.

    but anyway its all working again now I will be more cautious in the future and check the changes before jumping in blind, silly mistake.  ::)


  • Netgate

    @regal81:

    a small note of interest to anyone if you reformat your drive to start fresh and you have a VPN you will need to remake the file in whatever directory you had it and impute username password.

    Another note is that you don't need those files any more. Use the username and password fields in the OpenVPN client config.