2.3 Quality monitoring not working



  • I had my ISPs DNS server as the monitoring IP but ever since this update, it, nor any other IP will work. I just get 100% packet loss. I'm able to run pings/traces to this IP using the Webgui as well.

    How can I fix this? I've been having issues with my ISP regarding sporadic high pings and packet loss and I've been using this to monitor it.

    I actually just noticed that none of the monitoring works.



  • Be sure that dpinger i running
    https://<pfsenselanip>/status_services.php

    And try send a sceenshout of this page :)
    https://<pfsenselanip>/status_gateways.php


    </pfsenselanip></pfsenselanip>



  • It says the gateways are offline? Nm, figured it out, had to disable "Block bogon networks" under WAN interface. Err, maybe not. Showed online when I checked the first time but offline again when I checked a second time.

    But quality monitoring still isn't working.



  • try and set 8.8.8.8 to monitor ip just to test if dpinger is totaly fuckd :)
    And try to reset the service



  • Still nothing. After I updated the Monitor IP, I checked the gateway status and it briefly said online though, but restarting the dpinger service did nothing after that.



  • If it was up to me i will backup my config and then re-install pfsense



  • I guess this is an issue that'll be addressed in a future update but for now I'll probably have to do a fresh install of 2.2.x since I need that feature to work.



  • Have you confirmed the ability to ping the address with the ping command? Assuming that works, try ping with size zero (-s 0) to see if that fails. If ping with size zero fails, you can set a data payload size in the advanced options in System/Routing/Gateways/Edit.



  • More than likely it's the 0 byte ping payload that's triggering a bug in something upstream of you (that is supposed to work, but doesn't in some cases). If you go to System>Routing, edit your gateway, set the payload to 1, it'll probably work. That may bring up the other possibility, combinations of advanced options that are no longer valid.



  • @cmb:

    More than likely it's the 0 byte ping payload that's triggering a bug in something upstream of you (that is supposed to work, but doesn't in some cases). If you go to System>Routing, edit your gateway, set the payload to 1, it'll probably work. That may bring up the other possibility, combinations of advanced options that are no longer valid.

    @dennypage:

    Have you confirmed the ability to ping the address with the ping command? Assuming that works, try ping with size zero (-s 0) to see if that fails. If ping with size zero fails, you can set a data payload size in the advanced options in System/Routing/Gateways/Edit.

    Looks like this was the issue, at least for ipv4. I set the payload to 1 and the gateway showed as online but the quality RRD graph still isn't showing anything.

    I also did a fresh install of 2.3 and it still doesn't work.



  • I've been playing around with the quality graphs when I have time and have found that it works if I set the Monitor IP as my external IP, but if I try and use my ISPs DNS server (which worked before), it no longer works, regardless of whether "Use non-local gateway" under System > Routing is toggled or not.

    Any help on this would be appreciated, these graphs are the easiest way to monitor packet loss and high pings from within my network as they come directly from the PC (PFSense box) connected to the modem rather than using my main PC connected to my PFSense box due to my ISP arguing that it's my router causing the issues.



  • @Apathia:

    I've been playing around with the quality graphs when I have time and have found that it works if I set the Monitor IP as my external IP, but if I try and use my ISPs DNS server (which worked before), it no longer works, regardless of whether "Use non-local gateway" under System > Routing is toggled or not.

    Sounds like you probably need to set a payload, as I noted above in this thread, and here.
    https://forum.pfsense.org/index.php?topic=110043.0



  • @cmb:

    @Apathia:

    I've been playing around with the quality graphs when I have time and have found that it works if I set the Monitor IP as my external IP, but if I try and use my ISPs DNS server (which worked before), it no longer works, regardless of whether "Use non-local gateway" under System > Routing is toggled or not.

    Sounds like you probably need to set a payload, as I noted above in this thread, and here.
    https://forum.pfsense.org/index.php?topic=110043.0

    Yes I've done this and all it did was make my Gateways show as online rather than offline, had no effect on the quality monitor though.

    Here's a pic of the settings: http://i.imgur.com/dT88vQw.png



  • @Apathia:

    Yes I've done this and all it did was make my Gateways show as online rather than offline, had no effect on the quality monitor though.

    Here's a pic of the settings: http://i.imgur.com/dT88vQw.png

    Uncheck "use non-local gateway", that's not applicable. Also looks like maybe you have your monitor IP set to your WAN IP, set that to 8.8.8.8 or something other than your own IP.



  • @cmb:

    @Apathia:

    Yes I've done this and all it did was make my Gateways show as online rather than offline, had no effect on the quality monitor though.

    Here's a pic of the settings: http://i.imgur.com/dT88vQw.png

    Uncheck "use non-local gateway", that's not applicable. Also looks like maybe you have your monitor IP set to your WAN IP, set that to 8.8.8.8 or something other than your own IP.

    It's set to monitor my isps dns server (prevents them from saying the issue is outside of their network), and it doesn't work regardless of whether or not "use non-local gateway" is checked. And yes, their dns server is pingable both from within pfsense and another pc on the network. I've also tried google dns server and it doesn't work either.

    The only way I've actually gotten it to work is if I do actually set it to my own wan IP, but that defeats the whole purpose of it.



  • If it pings from Diag>Ping with WAN chosen as the source, then the only difference between that and what dpinger is doing for gateway monitoring is the payload size. 1 is still considerably smaller than what typical ping utilities use. Granted I've yet to hear of anything having issues at a 1 byte payload, it was just no payload that triggers bugs in other things dropping valid traffic. Try setting the payload to 56, which is the default of ping. That makes it the same as what Diag>Ping does.

    That IP doesn't ping at all from here, but maybe it does within your ISP's network.



  • To match the default behavior of ping, you need to use a data payload of 56 bytes. When ping reports that it received 64 bytes, the ICMP header (8 bytes) is included in the count.



  • Works just fine in Diag > Ping but still nothing in the quality graphs even with the increased payload.

    My ISP has a total of 4 DNS servers (64.71.255.204, 64.71.255.198, 2607:f798:18:10:0:640:7125:5204, and 2607:f798:18:10:0:640:7125:5198) and I've tried using them all to no avail.




  • Can you share a screenshot of your gateway status page (Status / Gateways)?

    And a screenshot of the config page for the gateway (System / Routing / Gateways / Edit)?



  • Yep.






  • Thanks for the correction, Denny.

    So that screenshot of the status screen confirms it's working fine. What does a screenshot of the graph look like?



  • This




  • Are all your other monitoring graphs fine? Any gateway names in the Graphs drop down other than those two? Seem to match up to the status page.



  • Everything else works fine (except for Queues/Queuedrops but I don't have any traffic shaping so it's not broken). Nothing else in the drop down menu.



  • Could you send me copies of your /var/db/rrd/WAN_DHCP-quality.rrd and WAN_DHCP6-quality.rrd files? Can download them under Diag>Command, or via scp.



  • I also reboot the system to see if it had any effect. It did not :(



  • Thanks, you can remove those now if you'd like. Files are sane, but their contents stop on April 12.

    Try moving those two files to a different filename, and reboot afterwards. Give it 5 minutes post-reboot to gather data. Does it work then?



  • Omg, I think that actually fixed it. It seems to actually be recording it now.

    Between 2.2 and 2.3, are there differences in how it records the info? The reason why the logs stop is because I updated while trying to keep the RRD data.



  • Glad that worked. Maybe the conversion on upgrade failed on your system. That RRD file is updated during upgrade since it had standard deviation now as well. Did you have any rrdtool logs in your system log?



  • What's weird is I first upgraded the system and then followed it up with a fresh install after a few days of it not working. When I did the fresh install, I didn't import anything and just set up the basic things and still no go for the quality monitor. I did eventually end up importing my old config to get a few other things back to what I had.

    As far as anything in the system logs, well I'll have to check later when I have access to it.
    EDIT: Nothing in the logs as far as I can see, anything specific I can search for or just rrdtool?



  • @Apathia:

    What's weird is I first upgraded the system and then followed it up with a fresh install after a few days of it not working. When I did the fresh install, I didn't import anything and just set up the basic things and still no go for the quality monitor. I did eventually end up importing my old config to get a few other things back to what I had.

    huh, yeah that's odd. The reinstall would have started with fresh rrd data files as long as the config you restored didn't include RRD data. So it shouldn't have happened in that case. Sure you didn't have RRD data in the restored config maybe?

    @Apathia:

    As far as anything in the system logs, well I'll have to check later when I have access to it.
    EDIT: Nothing in the logs as far as I can see, anything specific I can search for or just rrdtool?

    Just rrdtool would suffice. 'clog /var/log/system.log | grep rrdtool'



  • @cmb:

    @Apathia:

    What's weird is I first upgraded the system and then followed it up with a fresh install after a few days of it not working. When I did the fresh install, I didn't import anything and just set up the basic things and still no go for the quality monitor. I did eventually end up importing my old config to get a few other things back to what I had.

    huh, yeah that's odd. The reinstall would have started with fresh rrd data files as long as the config you restored didn't include RRD data. So it shouldn't have happened in that case. Sure you didn't have RRD data in the restored config maybe?

    @Apathia:

    As far as anything in the system logs, well I'll have to check later when I have access to it.
    EDIT: Nothing in the logs as far as I can see, anything specific I can search for or just rrdtool?

    Just rrdtool would suffice. 'clog /var/log/system.log | grep rrdtool'

    No results when searching for rrdtool.

    I did have the data in my old config, but I didn't restore it right away. After the upgrade I backed it up then did a factory reset but that still didn't work so I did a fresh install. After waiting a day or two with it still not working, I did finally restore it to get the misc settings that I hadn't bothered to go through initially.


Log in to reply