Set ath txpower on boot



  • How can I set the txpower on boot? I have searched for a sysctl set, I've tried adding the following to /etc/rc.conf.local

    ifconfig_ath0_wlan0="txpower .5"
    

    No sysctl that I can figure out and that in the rc.conf.local doesn't work (I suspect it's too early)

    This is the card info

    ath0_wlan0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 0.5</up,broadcast,running,simplex,multicast>
    

    I can set txpower via the cmdline (ifconfig ath0_wlan0 txpower .5), but I want the setting to persist over reboots. Rebooting, and it defaults back to 30. It's a shame there isn't a drop down or a box to set it on the interface screen.

    I'm running the card as an AP. I really don't want to hear the standard "get a dedicated AP" argument that I see everyone say. This machine has a very specific/specialized purpose, and it acting as an AP for one client, once or twice a year is a must.

    I would just rather set the txpower on the floor (as access will be in close proximity) until I can come up with a way to make a hardware push-button to turn the wireless on and off.

    added: pfsense 2.3