After 2.3 update and clean install squid and squidguard will not start



  • After I did the upgrade to to 2.3 I could not get squid and squidguard to start or up or download any of the blacklists for squidgaurd so I did a full install with the same results I have read every document I I good find and watched about 20 youtube videos on squidguard and can not find what I am doing wrong what should be my next step ?? please help



  • ok it looks like I am missing  /usr/pbi/squidguard-amd64/bin/squidGuard: (2) No such file or directory
    squid: ERROR: No running copy how do I add this file ?



  • Allright go to squidguard then logs then to filter log make sure squidguard shows ready for requests IF NOT then sometime is wrong with the DB of blacklist I had one pfSense box with that issue had to add the stuff I wanted manually

    https://forum.pfsense.org/index.php?topic=109051.0



  • Hy,

    a have the same problem. Here is the result:

    https://forum.pfsense.org/index.php?topic=110119.0



  • I did all that and still no luck there are people online as soon as they get off line I will reboot and see if that helps



  • Hellos guys, sorry for my english…

    I´m update my pfsense to 2.3 and the squid and quidguard dont work.. I tried to update the blacklist and dont work.

    See the error log:

    Crash report begins.  Anonymous machine information:

    i386
    10.3-RELEASE
    FreeBSD 10.3-RELEASE #5 05adf0a(RELENG_2_3_0): Mon Apr 11 18:56:05 CDT 2016    root@ce23-i386-builder:/builder/pfsense-230/tmp/obj/builder/pfsense-230/tmp/FreeBSD-src/sys/pfSense

    Crash report details:

    PHP Errors:
    [21-Apr-2016 10:31:43 America/Bogota] PHP Stack trace:
    [21-Apr-2016 10:31:43 America/Bogota] PHP  1. {main}() /tmp/squidGuard_blacklist_update.sh:0
    [21-Apr-2016 10:31:43 America/Bogota] PHP  2. sg_reconfigure_blacklist() /tmp/squidGuard_blacklist_update.sh:5
    [21-Apr-2016 10:31:43 America/Bogota] PHP  3. sg_update_blacklist() /usr/local/pkg/squidguard_configurator.inc:2095
    [21-Apr-2016 10:31:43 America/Bogota] PHP  4. squidguard_ramdisk() /usr/local/pkg/squidguard_configurator.inc:2131
    [21-Apr-2016 10:31:43 America/Bogota] PHP  5. mkdir() /usr/local/pkg/squidguard_configurator.inc:1978



  • The same problem, help solve



  • This is how I fixed mine in Squid General settings at the bottom of the page I clicked on show advanced options and in the Integrations box there was a code I removed completely (copy and save in case this is not your problem) went to the top of the page and hit the start button and it now works perfect I messed with it for a week before I figured that out.

    Here is the command I removed url_rewrite_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;url_rewrite_bypass off;url_rewrite_children 16 startup=8 idle=4 concurrency=0



  • @dgall:

    This is how I fixed mine in Squid General settings at the bottom of the page I clicked on show advanced options and in the Integrations box there was a code I removed completely (copy and save in case this is not your problem) went to the top of the page and hit the start button and it now works perfect I messed with it for a week before I figured that out.

    Here is the command I removed url_rewrite_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;url_rewrite_bypass off;url_rewrite_children 16 startup=8 idle=4 concurrency=0

    I have the same problem.
    i tried this but without luck.



  • I think its safe to say its broken - would be good for someone to publish a how to guide with a fix, it possible.



  • https://forum.pfsense.org/index.php?topic=105399.msg588219#msg588219

    This is how I fixed mine…

    Thanks you Jimp...



Log in to reply