[SOLVED] OVPN Users not communicating with LAN



  • Hello,

    My OpenVPN configuration:
    Part1:

    Part 2:

    My Firewall - Rules - OpenVPN :

    My Firewall - NAT - Outbound : 

    My LAN is 192.168.0.0/22 :

    I have openvpn client connected on 192.168.2.6 and the client cannot access any of the LAN machines.  I tried connecting to a smb share no go, i try to ping the local ip 192.168.0.22 from the openvpn client and it timesout.  I try pinging 192.168.2.6 from my LAN machines and it times out.

    I go to my pfsense Diagnostics - Ping and i can ping 192.168.2.6 with no problems from either source, OpenVPN or LAN.

    Can somebody please tell me what am i doing wrong?



  • your pictures are missing (part1/part2/My Firewall - Rules - OpenVPN/My Firewall - NAT - Outbound : )



  • Maybe the client has a local LAN address of your LAN 192.168.0.0/24.
    That address range is often the default at routers and users don't change that. Also your VPN tunnel network range is no good idea. It's better to change it to an inconvenient range.



  • ugh i dont know why my pictures failed lol

    but viragomann was right! I changed my vpn tunnel to 10.10.10.0 and everything works! thank you!