Strange pfSense+VMware Problem



  • I have 1 PC running W2k3R2 (Bigboy) that is the fileserver and running VMware Server. I have one onboard NIC connected to the local switch and a 4-port PCI network card. Each one of those ports, I've unbinded everything like "Internet Protocol (TCP/IP)" and "Client for Microsoft Networks" but left the "VMware Bridge Protocol" enabled. I'm running pfSense in a VM with 2 virtual NICs bound to 2 of the physical NICs. One NIC connects to my cable modem and the other connects up to my local switch. Everything runs perfectly on the network except when I RDP into 'Bigboy' from outside the network. It connects and stays connected for maybe 30-45 seconds then the connection drops. I try pinging my external IP and it times out for about 1-2 minutes and then magically comes back to life. It happens every time I RDP into that server, but what is strang is that I can RDP into my desktop then RDP from there to the server just fine. Any ideas?



  • I fixed it myself thank you!

    I went into the RDP-TCP transport link in Terminal Services and changed the NIC binding from any to the Onboard NIC that's connected to the internal switch. But after I did that, it shut the pfSense VM off for some reason.

    I rebooted the host box and then pfSense came back up. I tested it from multiple places and it works now.



  • I am having this exact same issue. However, I made the changes that you made, and it still doesn't work. The thing is, I removed one of the NIC's. So the machine NIC and PFSense's LAN NIC are the same physical NIC. (I needed a NIC in one of my other machines).

    I'm thinking that is the problem, but I was wondering if anyone has any ideas. Or do you know on a more technical level, as to why that fixed it?


Log in to reply