Squid Service Stops Each Time After Restarting with Upgrade 2.3



  • Hello,

    The upgrade to 2.3 went relatively smooth but I do have currently one issue with the squid package after the upgrade.
    Each time I start the squid service it will shortly afterwards stop. What I found in the cache log file is shown below.
    Your help would be much appreciated.

    Thanks,

    Maximum Resident Size: 72544 KB
    Page faults with physical i/o: 0
    2016/04/16 16:48:13 kid1| Starting Squid Cache version 3.5.16 for amd64-portbld-freebsd10.3…
    2016/04/16 16:48:13 kid1| Service Name: squid
    FATAL: UFSSwapDir::openLog: Failed to open swap log.
    Squid Cache (Version 3.5.16): Terminated abnormally.
    CPU Usage: 0.026 seconds = 0.026 user + 0.000 s



  • I have noticed the same behaviour, and also CPU occupancy has been ALOT higher.
    Ive restarted PFSense, un-installed squid, re-installed, and restarted again etc. with the same results.

    Any advice would be appreciated.

    Thanks

    2.3-RELEASE (i386)
    built on Mon Apr 11 18:12:06 CDT 2016
    FreeBSD 10.3-RELEASE
    Dual-Core AMD Opteron™ Processor 2212 HE
    Current: 1000 MHz, Max: 2000 MHz
    2 CPUs: 1 package(s) x 2 core(s)
    1 Gig RAM



  • I also noticed this, I had to remove squid because it won't start.
    if I remove squid and and untick the box that remembers all the settings it also doesn't seem to work, it keeps all the previous settings which I suspect might be corrupt or something.



  • Same here. Squid Service stops after a brief period of time. Reinstalling package does not help.

    squid.log.txt
    squid.log2.txt



  • Same here. Could it be that the config file of the old install is not compatible to the new one?

    How can I do a clean reinstall without using the old config? Deleting the config file from /usr/local/etc/squid didn't work…

    The error message I get after restarting and doing a request through the proxy (transparent) is the following one:

    
    17.04.2016 21:46:33	assertion failed: store_swapout.cc:289: "mem->swapout.sio == self"
    17.04.2016 21:46:33	pinger: Initialising ICMP pinger ...
    17.04.2016 21:46:32	Service Name: squid
    17.04.2016 21:46:32	Starting Squid Cache version 3.5.16 for amd64-portbld-freebsd10.3...
    
    


  • Here's another post about similar issues. The solution so far seem to work in my case and Squid seems to be enable along with SquidGuard.

    https://forum.pfsense.org/index.php?topic=110119.0

    Hope this is helpful.



  • Hmmm, with regard to the linked issue: my cache structure looked fine and had the right permissions (but I only checked at the top level) and I already deleted the /usr/pbi files. Nevertheless, after doing a

    
    cd /var/squid
    chown -R squid cache/
    
    

    it seems to be working for now… Thanks!



  • cd /var/squid
    chown -R squid cache/

    doesn't work for me, anyone have any other suggestions?

    Why isn't unticking

    Keep Settings/Data

    working? it keeps all the settings, how can I force it to remove old config ?

    Regards
    Jamie



  • @kiekar:

    Hello,

    The upgrade to 2.3 went relatively smooth but I do have currently one issue with the squid package after the upgrade.
    Each time I start the squid service it will shortly afterwards stop. What I found in the cache log file is shown below.
    Your help would be much appreciated.

    Thanks,

    Maximum Resident Size: 72544 KB
    Page faults with physical i/o: 0
    2016/04/16 16:48:13 kid1| Starting Squid Cache version 3.5.16 for amd64-portbld-freebsd10.3…
    2016/04/16 16:48:13 kid1| Service Name: squid
    FATAL: UFSSwapDir::openLog: Failed to open swap log.
    Squid Cache (Version 3.5.16): Terminated abnormally.
    CPU Usage: 0.026 seconds = 0.026 user + 0.000 s

    You'd probably have to recreate the cache and swap files.

    stop the squid service, login to shell

    cd /var/squid/cache

    rm -rf *

    squid -z

    Restart the squid service.

    That is, if you are ok with deleting all the previous cache files.

    Works for me.


Log in to reply