Ustawienie routingu



  • Witam,

    Do tej pory miałem prostą konfigurację Lan (192.168.13.0) <-> pfsense <-> Internet.

    Dostałem jednak dostęp do pewnych zasobów poprzez open VPN, jako że kilka komputerów musi z niej skorzystać postanowiłem, zestawić to połączenie na moim pFsense

    Skonfigurowałem połaczenie (VPN/OpenVPN/Clients),
    skojarzyłem połaczenie (InterfacesInterface Assignments)

    I teraz problem, bo wszystko mi przechodzi przez ten VPN, a ja chciałbym tak, że calość idzie jak szła do tej pory przez WAN,
    a tylko ruch do sieci 10.0.0.0.0 i 10.0.1.0 prze to połączenie openvpn.

    Domyślam się, że to trzeba zrobić tutaj: Firewall/NAT/Outbound.

    Obecnie mam zaznaczoną opcje Automatic outbound NAT rule generation. (IPsec passthrough included) i tylko 2 automatyczne reguły:

    | Interface | Source | Source Port | Destination | Destination Port | NAT Address | NAT Port | Static Port | Description |
    | WAN | 127.0.0.0/8 192.168.13.0/24 | * | * | 500 | WAN address | * | | Auto created rule for ISAKMP |
    | WAN | 127.0.0.0/8 192.168.13.0/24 | * | * | * | WAN address | * | | Auto created rule |

    Zakladam, że muszę zmienic opcje na: Manual Outbound NAT rule generation. (AON - Advanced Outbound NAT) i skonfigurowac to ręcznie.

    Jako, że nigdy tego nie robiłem, zwracam się z prośbą o to jak to skonfigurować.

    Pozdrawiam
    Michał



  • Powinieneś w Phase2 poprawnie określić jakie masz zdalne sieci. Routing ustawi się automatycznie na podstawie tych wpisów. Prawdopodobnie w tej chwili masz za szeroki zakres tam ustawiony stąd routing na wszystko przez VPN.



  • To nie pomaga, w konfiguracji klienta open VPN nie mam możliwości konfiguracji fazy 2…
    Ale dodałem w ustawieniach Tunnel Settings:
    IPv4 Tunnel Network: 10.0.1.0/30
    IPv4 Remote Network Network:  10.0.1.0/24

    Ale efekt, ze wszystko i tak jest pchane przez openvpn...


Log in to reply