[Solved]After reboot or disconnect - Unrecognized option or missing parameter..



  • Hi,

    I use the advanced configuration filed to connect to an VPN Server. It works great until disconnection by network or reboot of pfsense.
    Then I get log entries like: openvpn 20375 Options error: Unrecognized option or missing parameter(s) in /var/etc/openvpn/client1.conf:35: 81782767e4d59c4464cc5d1896f1cf60 (2.3.9)

    When I look at adnaced configuration, it has rearranged the lines with the < > characters, like:

    reneg-sec 432000<tls-auth>-----BEGIN OpenVPN Static key V1-----
    and
    -----END OpenVPN Static key V1-----</tls-auth>
    

    If i just line break the lines in the advanced editor and press save it works, until next disonnection or reboot of pfsense.

    I have this issue on booth my client VPN connections.

    Could it have something to do that I created the connections on 2.3beta? Using stable now, but I have always had this problem..

    I guess it reminds of this topic that I found: https://forum.pfsense.org/index.php?topic=80375.msg438377#msg438377

    Thanks for any help/input.

    SOLVED: I did a clean install of pfsense 2.3 and now it works. Before I had just updated from the beta.



  • Don't put <tls-auth>into the advanced config like that, use the GUI's TLS key field.</tls-auth>



  • @cmb:

    Don't put <tls-auth>into the advanced config like that, use the GUI's TLS key field.</tls-auth>

    Thanks for the tip. I tried that but then got AUTH: Received control message: AUTH_FAILED.

    …But then I tried some more and it worked! Thank you!  :)



  • Strange thing, it worked with the movement of tls key, but still same kind of problem.

    But if I insert a space (or any char) somewhere in the key windod and deletes it, ans same thing in advanced window (which looks like:

    persist-key;
    persist-tun;
    remote-cert-tls server;
    key-direction 1;
    reneg-sec 432000
    

    and save, then I can connect. otherwise I get auth failed after disconnection.


Log in to reply