PFsense 2.3 gateway routing problemi.



  • Merhaba,

    2.1.6'dan 2.3 sürüme upgrade yaptım ancak rules >lan_interface içinde oluşturduğum gateway routing çalışmıyor. 2.1'de routing'ler problemsiz çalışıyordu.

    Görsel EK'te gönderilmiştir.

    Kural en üstte.

    Source: ilgili makine lan_ip

    Kolay gelsin.



  • merhaba,
    tüm port / prot. için mi route çalışmıyor ?
    squid kullanıyorsanız, web trafiğini default gw üzerinden çıkartıyordur.
    kontrol etmenizde fayda var.



  • @tcjackal:

    merhaba,
    tüm port / prot. için mi route çalışmıyor ?
    squid kullanıyorsanız, web trafiğini default gw üzerinden çıkartıyordur.
    kontrol etmenizde fayda var.

    Evet tum portlar ve protokoller icin route kurali yazili.

    Squid ile filtreleme yapiliyor.

    Squid proxy portu icin kaynak lan_ip olan 3228 portu ile bu gateway'den ciksin seklinde bir kural yazip deneyecegim simdi.

    Tesekkurler.



  • https://snapshots.pfsense.org/  adresinden en güncel paketi kurarak deneyiniz. zira 2.3.1 için bir çok bug giderildi. giderilen veya açık buglara  bakabilirsiniz. https://redmine.pfsense.org/projects/pfsense/roadmap



  • @ondokuz:

    https://snapshots.pfsense.org/  adresinden en güncel paketi kurarak deneyiniz. zira 2.3.1 için bir çok bug giderildi. giderilen veya açık buglara  bakabilirsiniz. https://redmine.pfsense.org/projects/pfsense/roadmap

    selamlar,  güncelleme yaptığım halde sorun devam  ediyor.  pfsense restart ettikten sonra  ilk birkaç saniye  online görünüyor sonra tekrar offline oluyor. çöüzümü bulan var mı ?



  • merhaba,
    outbound nat tarafında, manual mod'a alarak, source host için, istediğiniz gateway'i  belirttiğinizde sorun devam ediyor mu ?



  • @tcjackal:

    merhaba,
    outbound nat tarafında, manual mod'a alarak, source host için, istediğiniz gateway'i  belirttiğinizde sorun devam ediyor mu ?

    Selam,
    örnek olarak nasıl bir kural yazmamız gerek ?





  • @tcjackal:

    merhaba,
    aşağıdaki link fikir verecektir.
    https://doc.pfsense.org/images/thumb/1/12/Ipsec-s2s-vork-15.png/700px-Ipsec-s2s-vork-15.png

    selam sorunu çözdüm sanırım

    system/Routing/Gateways  tarafında  gateway  gelişmiş ayarlarından Data Payload  da "0" değeri vardı  onu "1"  yapınca sorun düzeldi.



  • merhaba

    aynı sorun bende de var, dediğiniz şeyi yaptım ancak olmadı. üstüne default gatewayi wan seçmeme rağmen bütün trafik opt1 den cıkıyor. test amaçlı bütün rule ları disable ettim (otomatik olanlar hariç).

    squid tarafında bir ayar mı yapmam gerekiyor yoksa?



  • merhaba,
    squid pasif mod'a alarak, trafik kurallarını yeniden düzenleyerek, test ettiniz mi ?



  • Merhaba

    Squid'i pasif moda aldığımda sorunsuz port yönlendirme ve gateway yönlendirme yapabiliyorum.

    Squidi açtığımda

    1- otomatikman opt1 den çıkarıyor trafiği. Default gateway wan olmasına rağmen hem de.
    2- hiç bir gateway yönlendirme ve firewall kuralı çalışmamakta.



  • pf ve squid üzerindeki yapılandırmanızı bilmemekle birlikte, aşağıdaki link'i referans alarak, tekrar deneyin.
    https://www.youtube.com/watch?v=pM2Wnqjp17s



  • Merhaba
    Cevaplar için çok teşekkür ederim.

    Videoda Multivan için ayarlamalar yapıyor ancak ben multivan kullanmıyorum, onun yerine belli başlı portlara gateway routing yapıyorum. Onun dışında squid ile ilgili bütün ayarlamalarım orasıyla aynı.

    wan ve opt bağlantılarım var, squid çalıştığında https olan bir ip bildirim sitesine girdiğimde (https://www.pfsense.org/ip.php) wan ipsi, http sitesine girdiğimde (http://www.ip.biz.tr/) opt ipsi görüyorum. Bu gözüken iplere rule kısmından hiç bir etkim olmuyor.

    Sistemde wan; bridge modda bağlanmış uydunet 10/10 simetrik tarife. opt; normal bağlanmış 20 mbit uydunet tarife.
    Modemlerimin gateway adresi aynı ispden olması nedeniyle olsa gerek, aynı.
    gatewaylerin weight ayarları da wan:1 opt:2 şeklinde.
    ancak squid bütün trafiği opt2 den cıkarıyor.

    Yabancı forumlardan, bloglara bakmadığım yer kalmadı dünden beri. kimisi squid ile firewall rulelları kullanılmıyor demiş. Ancak port yönlendirme benim için hayati bir önem arzediyor, ha keza log imzalama yapmam gerektiğinden squid kullanıyorum. Bu yüzden ne yardan ne de serden vazgeçmem mümkün.

    İyi günler



  • local rules ve status/ interface ekranlarını paylaşın.
    squid varsayılan olarak, default gw üzerinden public yöne çıkar.
    aşağıdaki satırı, squid / custom rules ekleyerek, tekrar deneyin.

    tcp_outgoing_address 'istediginiz gw'



  • tcjackal'a katılmakla birlikte benim de konu hakkında nacizane önerim var.

    Squid'in dinlediğii interface üzerinde oluşturacağınız firewall gateway routing kurallari çalışmayacaktır. 5651 URL loglama için Squid kullanmanız şart değil FreeBSD üzerinde çalışan herhangi bir 80 portunu sniff edip loglayabileceğiniz yazılımları araştırabilirsiniz.

    Örneğin : tcpflow,httpry,tcpdump gibi gibi.



  • Merhaba

    @tcjackal:

    local rules ve status/ interface ekranlarını paylaşın.
    squid varsayılan olarak, default gw üzerinden public yöne çıkar.
    aşağıdaki satırı, squid / custom rules ekleyerek, tekrar deneyin.

    tcp_outgoing_address 'istediginiz gw'

    istediğim gateway ipsini yazacağım fakat iki gateway ipsi de aynı direk isim yazarsam olur mu acaba?

    @Jig:

    tcjackal'a katılmakla birlikte benim de konu hakkında nacizane önerim var.

    Squid'in dinlediğii interface üzerinde oluşturacağınız firewall gateway routing kurallari çalışmayacaktır. 5651 URL loglama için Squid kullanmanız şart değil FreeBSD üzerinde çalışan herhangi bir 80 portunu sniff edip loglayabileceğiniz yazılımları araştırabilirsiniz.

    Örneğin : tcpflow,httpry,tcpdump gibi gibi.

    loglama sistemlerinde squid kullanıldığını gördüm. diğer sniff yapan programlarla da o düzeneği kurmam mümkün olur mu ki?

    bir araştırayım ben

    teşekkür ederim.



  • squid tarafında gateway yazarken,

    • bridge mod'da olan hattınızdaki public gw adresi
    • router mod'da olan modemin gw adresini yazmanız yeterli.

    @JigSaw'ın belirttiği gibi, trafiği dinleyerek loglama yapılabilir.
    80 ve 443 portlarını baz alabilirsiniz.



  • Tekrar Merhaba

    squid disable olduğu halde düzgünce loglama yapıp imzalıyor sistem.
    Çok işime geldi ancak neden ve nasıl olabilir çözemedim.

    edit: disable etmeden önceki tarih loglarını yineliyormuş.

    Squidi silip default gateway ayarlayıp tekrar yükledim, oldu. Port yönlendirmeler sorunsuz çalışıyor. http portları da istediğim gatewayden default çıkıyor.