SquidGuard error on Common ACL page after enabling blacklists in 2.3



  • After reading about all the changes in 2.3 I decided to take it for a test drive on a spare system I had on hand.

    My process:  the system already had a fresh install of 2.2.6 on it (without any configuration or packages, not even the setup wizard had been run).  I booted, did the 2.2.6 setup wizard, applied the upgrade to 2.2.3, then installed squid & squidguard.  I did some basic configuration on squid, started it, then started configuring squidguard.  I added the url for my blacklist, enabled the blacklist, then went to the Blacklist tab to download it and build the db.  That all went swimmingly.  Next I went to the Common ACL tab, and found this error at the top (also, the usual tool for selecting the Target Rules is missing, and it's just a text box):

    Warning: gettext(): msgid passed too long in /usr/local/www/classes/Form/Input.class.php 
    on line 250 Call Stack: 0.0001 231736 1\. {main}() /usr/local/www/pkg_edit.php:0 0.0525 
    1681168 2\. Form->__toString() /usr/local/www/pkg_edit.php:1526 0.0525 1681528 3\. 
    implode() /usr/local/www/classes/Form.class.php:102 0.0525 1681664 4\. Form_Section->__toString()
    /usr/local/www/classes/Form.class.php:102 0.0526 1682064 5\. implode()
    /usr/local/www/classes/Form/Section.class.php:96 0.0526 1682408 6\. Form_Group->__toString()
    /usr/local/www/classes/Form/Section.class.php:96 0.0526 1684800 7\. implode()
    /usr/local/www/classes/Form/Group.class.php:142 0.0527 1684912 8\. Form_Input->__toString()
    /usr/local/www/classes/Form/Group.class.php:142 0.0527 1685208 9\. gettext()
    /usr/local/www/classes/Form/Input.class.php:250
    

    I did some searching in the forums to see if anyone else had experienced this, and I found this thread, which has a similar error on the 2.3 RC:  https://forum.pfsense.org/index.php?topic=100604.0

    I tried disabling the blacklist, and the error disappeared.  I kinda need the blacklist though.  :P

    Thanks!  PS the new web interface is great!



  • Also note that this doesn't occur under the Groups ACL tab, and I can set up my blacklists as normal.



  • I am having this problem too. Same situation.

    This what I do for now:

    In the file /usr/local/www/classes/Form/Input.class.php, edit line 250 where there is
    $help = gettext($this->_help);
    change for this
    $help = $this->_help;

    At least the error stopped showing, the page is showing normal too. Looks like everything works fine until now.



  • Yes, that worked for me too.  Thanks!

    Another workaround (which is what I used) is to use Group ACL lists instead.  That is unaffected.


Log in to reply