Setup HAProxy in 2.3 - errors on default settings



  • Using:

    2.3-RELEASE (amd64)
    built on Mon Apr 11 18:10:34 CDT 2016
    FreeBSD 10.3-RELEASE

    Trying to use HAproxy to send various web sites to different web servers (Http and HTTPS) using 1 wan IP.

    Downloaded HaProxy version 0.44 and created a default configuration using the default template "Serving multiple domains from 1 frontend".  Once the files are automatically created and before I start modifying them,  When I try to save the configuration I get the following errors

    Errors found while starting haproxy
    [ALERT] 119/145238 (94576) : parsing [/var/etc/haproxy_test/haproxy.cfg:26] : 'timeout' expects 'retry' and <time>as arguments.
    [ALERT] 119/145238 (94576) : parsing [/var/etc/haproxy_test/haproxy.cfg:27] : 'hold' expects an <event>and a <time>as arguments.
    [ALERT] 119/145238 (94576) : <event>can be either 'valid', 'nx', 'refused', 'timeout', or 'other'
    [ALERT] 119/145238 (94576) : Error(s) found in configuration file : /var/etc/haproxy_test/haproxy.cfg
    [ALERT] 119/145238 (94576) : Fatal errors found in configuration.

    I then tried filling the items required and still get similar errors. How can I fix? is there a easy to follow tutorial on how to do what I'm trying to do.

    Thanks

    CJB</event></time></event></time>



  • On 'settings' tab either remove the dns server, under the "Global DNS resolvers for haproxy" section. Or fill in the 3 times there. There should have been default values, but apparently they don't work..

    Will fix those default values in a day or two.


Log in to reply