Pfsense 2.3 dpinger (gateway monitering daemon) stops


  • my system has 4 network cards after upgrading from 2.2.6 to 2.3 i remove one network card and restart after that dpinger service stops and never start again even though i try to manually start but fail.


  • Anything related to dpinger in your system log? What does your gateways log contain?


  • When I updated to 2.3, the dpinger didn't start anymore. The log shows

    May 24 07:55:22 php-fpm 22948 /status_services.php: Error starting gateway monitor for WAN_PPPOE
    May 24 07:55:22 php-fpm 22948 /status_services.php: The command '/usr/local/bin/dpinger -S -r 0 -i WAN_PPPOE -B (my ip here) -p /var/run/dpinger_WAN_PPPOE
    (my ip here)8.8.8.8.pid -u /var/run/dpinger_WAN_PPPOE(my ip here)8.8.8.8.sock -C "/etc/rc.gateway_alarm" -d 0 -s 500 -l 2000 -t 3000 -A 1000 -D 500 -L 20 8.8.8.8 >/dev/null' returned exit code '1', the output was ''

    I didn't understand anything about this log, but I went to the Routing configurations (System>Routing) to check if something was wrong there. For me, was everything ok. Anyway, I removed the Google DNS IP (8.8.8.8 ) just for testing and then I clicked on SAVE. So, thats when the problem comes.

    I couldn't save, because there was errors to correct according the pfsense:

    The following input errors were detected:
    The time period needs to be greater than twice the probe interval plus the loss interval.

    I never changed the Time Period. It was the default, 3000. So I just changed to 3001, saved and the dpinger started again by itself.

    Hope it can helps you too.  :)


  • The time period is specified in milliseconds. The default value is 60000.


  • Btw, version 2.3.1 has code to detect and correct an invalid dpinger configuration when upgrading.


  • @dennypage:

    Btw, version 2.3.1 has code to detect and correct an invalid dpinger configuration when upgrading.

    I was in 2.2.4 and I went directly to 2.3.1.
    I don't really know what was the default value on 2.2.4. If you're saying it was 60000, I believe it. I just know that changing the value to 3001 solved the problem here. Manually.


  • The default in 2.3.x is 60000. I would recommend using the default value.

    If you went directly to 2.3.1 it should have detected and corrected an invalid configuration. There may be something in your 2.2.4 config that we didn't account for. If you still have the 2.2.4 config file available, would you mind posting a snippet containing the gateway monitoring config? If you prefer, you can also PM me. Thanks.


  • too

    Denny I just went from 2.2.1 to 2.3.2-release

    dpinger also stopped for me and no gateways info in the dashboard

    Putting in 60000 on each WAN solved it so thanks (they were 3000)