Acceso a FTP desde wan



  • Buenas tardes, tengo un problema con unos servidores FTP, antes de pfsense usabamos iptables y no habia problemas, pero ahora que nos hemos pasado a pfsense estamos un poco verdes todavia, parecia que todo iba bien  pero hoy nos hemos encontrado con que no podemos acceder a los servidores FTP desde fuera.

    he estado leyendo post sobre este tema y hay mucho que leer, pero todo es muy viejo, parece que en versiones mas recientes el procedimiento ha cambiado un poco…

    lo único que he hecho es añadir las reglas en el nat para redireccionar al servidor FTP, pero no se que mas tenemos que hacer, he leído sobre FTP proxy, ftp pasivo... pero estoy muy perdido...

    alguien me puede guiar un poco? saludos!



  • si, pero nos ayudaria si expones una topologia como para guiarnos



  • @elbocha01:

    si, pero nos ayudaria si expones una topologia como para guiarnos

    tengo una red con distintos servidores, entre ellos tengo 3 ftp, y todo ello detras de un pfsense, una ip fija a la que accedemos desde fuera, el pfsense mediante nat se encarga de redireccionar todo a los diferentes servidores, el problema es cuando quiero utilizar una aplicacion como filezilla para conectar, ya que por comandos parece que si funciona



  • Mira en mi caso tengo, soy de arg.

    Modem Arnet –- PfSense ---- Server ftp

    Modem: bridge al PF
    PfSense: WAn ip publica, Lan dhcp, Esepto los servidores. firewall rules, puertos 2000 // 2001 // 53332 // 53333 abiertos para el ftp, y configurado en el server ftp esos puertos, asi funciona en modo pasivo // activo el server ftp, y la verdad que nunca un problema.



  • explico un poco mas mi caso, tengo reglas que me permiten llegar hasta el servidor ftp por los puertos 20, 21 y 9029, 9030

    en el nat tengo añadido una regla
    any -> this firewall -> 9029 -> servidorFTP -> 21

    despues de eso, me intento conectar con un cliente ftp a la IPpublica:9029… pero nada
    estoy haciendo algo mal?



  • La verdad que algo no anda del todo bien, fijate se subir una captura de pantalla con las reglas que tengas correspondiente al tema, abajo donde posteas tenes el link attachments and other options, subi fotito :)

    Por las dudas pregunto, tenes la ip publica en el PfSense o algun otro router antes? no sera cosa que si hay otro router le tengas que abrir el puerto a ese otro tambien.

    Podes probar tambien de abrir todos los puertos en la wan para que pase todo el contenido, SOLO PARA PROBAR!!!
    agregar una regla arriba del todo que diga pass any!  ;)



  • @elbocha01:

    La verdad que algo no anda del todo bien, fijate se subir una captura de pantalla con las reglas que tengas correspondiente al tema, abajo donde posteas tenes el link attachments and other options, subi fotito :)

    Por las dudas pregunto, tenes la ip publica en el PfSense o algun otro router antes? no sera cosa que si hay otro router le tengas que abrir el puerto a ese otro tambien.

    Podes probar tambien de abrir todos los puertos en la wan para que pase todo el contenido, SOLO PARA PROBAR!!!
    agregar una regla arriba del todo que diga pass any!  ;)

    Gracias elbocha01, voy a intentar hacer un par de pruebas con lo que comentas, si no consigo nada, probare a subir un pantallazo de como tengo las raglas

    saludos!



  • todavia sigo dandole vueltas al tema…

    tengo 2 ftp y en los dos me da el mismo mensaje...

    Conectando a 0.0.0.0:0000
    Estado: Conexión establecida, esperando el mensaje de bienvenida...
    Estado: Servidor no seguro, no soporta FTP sobre TLS.
    Estado: Logged in
    Estado: Recuperando el listado del directorio...
    Comando: PWD
    Respuesta: 257 "/home/carpeta"
    Comando: TYPE I
    Respuesta: 200 Switching to Binary mode.
    Comando: PASV
    Respuesta: 550 Permission denied.
    Comando: PORT 172,26,1,112,237,165
    Respuesta: 500 Illegal PORT command.
    Error: Error al recuperar el listado del directorio

    he estado mirando de que puede ser pero todavia no lo consigo solucionar...





  • @yraul:

    Leistes este post

    https://forum.pfsense.org/index.php?topic=48622.msg455154#msg455154

    si… pero no entiendo nada  :o

    creo que en las nuevas versiones no hay nada de ftpproxy no?

    yo por lo menos no tengo nada de eso activado, solo tengo las reglas, que permiten acceso por el puerto 9029-9030 a la ip del servidor, que tambien permita 20-21 a al servidor ftp, y en el nat redirecccionado lo que llega por los puertos 9029-9030 a la ip del ftp, nada mas

    tengo otro firewall con un ftp detras y me funciona bien...y he hecho lo mismo en los 2

    que significa el error que me esta saltando?


Log in to reply