Implementacion de Pfsense con SW Core (Enrutamiento)



  • A todos ..
    Muy Buen dia
    Primero que cualquier cosa quiero agradecer cualquier ayuda que puedan brindarme en medio de este proceso …

    El caso es el siguiente
    Poseo una red en la que tengo actualmente varias VLANS las cuales tienen enrutamiento a traves de un SW Core (172.17.1.230) en el cual estan creadas todas, enviando a varios backbone a traves de puertos trunk. (Cabe mencionar que no tengo ningun problema de enrutamiento entre ellas).

    Mi conexion a internet estoy gestandola con un router cisco 2900 (172.17.1.245) y todo funciona perfecto sin ningun filtrado y demas, pero debo mencionar que mi canal ya esta al limite asi que lo que me propongo es reemplazar ese RW por el pfsense en el cual tengo el siguiente laboratorio montado.

    creee una maquina virtual instale pfsense con 2 interfaces de red LAN (172.17.1.250) sin GW y WAN (IP Publica dada por el ISP) ... instale al mismo tiempo otra maquina virtual con cliente de win8 (172.17.1.120) con GW 172.17.1.250 y realice en pfsense todas las adecuaciones con squid en modo transparente y cache local .. filtrado (face an Youtu) y algunas reglas de FW permitiendo el trafico con los puertos 53,80,443 implemente un certificado y realice activacion del supervisor de HTTPS para lograr los bloqueos pertinentes ... y bueno hechas las pruebas en mi cliente virtual ... funciona perfecto ...

    lo curioso es que cuando entro a mi SW Core y le digo que deje de enrutar lo que no conozca a RW (172.17.1.245) y lo enrute a pfsense (172.17.1.250) no funciona nada ...

    le he puesto rutas estaticas a mi pfsense para que cualquier peticion de las vlans pueda ser respondida tomando como referencia unas practicas que tuvimos que hacer con TMG pero aun nada ....

    le envie todas las vlans al puerto donde esta conectado el pfsense, cree las vlans y las asigne pero sigue sin funcionar ...

    se que es un tema de enrutamiento porque cuando hago el cambio que mencione arriba en mi SW Core para que pregunte a pfsense el intenta resolver la etiqueta del navegador cambia como si se fuera a responder la peticion pero es como si se quedara sin camino pues me saca error de DNS _PROBE ....

    Alguien ha hecho alguna implementacion parecida que pueda brindarme su ayuda .... lo unico que quiero es que lo que me funciona con mi VClient funcione con mi red en Produccion ....

    Estoy muy atento y agradezco la ayuda de nuevo ...

    Saludos



  • Buen día amigo

    Deja que el switch de core sea solo capa 2, y deja el enrutamiento a pfsense, que también puede manejar  vlans, así te quitas problemas.



  • Muchisimas Gracias por responder ..
    Ahora la pregunta es …
    Por cada VLAN debo tener una interface para enviarla mi core?

    Si es de esta forma no tengo posibilidad .... pues son varias ...

    tienes algun otro camino que puedas brindarme ...?



  • Buen día

    Recuerda que las VLAN son interfaces virtuales con redes virtuales, por ende solo necesitas una sola interfaz mira este tutorial

    https://doc.pfsense.org/index.php/VLAN_Trunking

    https://www.highlnk.com/2014/06/configuring-vlans-on-pfsense/



  • Aleximper …
    Muy Buen dia
    desde ya te doy Muchisimas gracias por tu soporte y ayuda ...
    estuve contemplando lo que me dijiste y bueno aunque no lo he hecho .. ya tengo navegación en todos los clientes de las diferentes VLANS ...
    solo me faltaba adicionar las reglas a nivel de interface WAN para que el trafico saliera .. pues no los reconoce dentro de la LAN net sino que tuve que crear rutas estaticas a las direntes VLANS con GW en mi Core y adicional agregar las reglas en la interface LAN como lo mencione anteriormente ...

    Solo tengo un inconveniente no puedo subir archivos a correos ... cuando hago test de velocidad no me arroja ningún trafico de subida en fin ... muy bien bajada pero nada de subida ...

    Tienes o alguien tiene algun concepto que pueda brindarme para esto ...?

    Salu2



  • Prueba…

    Firewall / Rules / Edit
    Extra Options
    Advanced Options [Display Advanced]
    State type: Keep  <–-- Cambiar Keep por Sloppy

    Debe quedar así:
    State type: Sloppy

    Prueba y comentas...

    Saludos


Log in to reply