Squid went slow and the admin interface becomes unresponsive



  • So the other day all of a sudden my proxy became slow. A few tabs reloaded, and then suddenly no thruput at all for a few minutes. At the same time I tried to login to the admin interface but no response. Actually I got a response about 20 seconds later. Logged in thru ssh and used top - nothing out of the ordinary. There is memory, there is disk space and there is cpu available. Normally when putting load on squid, I see loads up to 5 or so. Now loads were consistently under 1.

    Everything is good after waiting for a few minutes, but consistently repeatable. Bypassing the proxy and everything works just fine.

    Did not see anything out of the ordinary in the squid logs either.

    Give me any hints, anything!

    No configuration changes for a few weeks.

    2.2.5-RELEASE (i386)
    Intel(R) Pentium(R) M processor 1.70GHz
    nanobsd (4g)
    2G RAM



  • To make it clear, no significant increase in load, memory or cpu. The admin interface becomes unresponsive as well as the proxy. Not sure at all what triggers this, but putting a couple of requests thru the proxy makes this happen every time.

    Tried to reboot, nothing changed.



  • I found that sometimes when there was an update for squid that if you did not delete the squid cache you can get this issue.



  • My cache file system is null and any memory cache should have been flushed when I rebooted right? This is a nanobsd-installation (running from a CF card).

    I did however command a "flush" just to make sure.


Log in to reply