Please test packages in the latest snapshot version.



  • All packages should be working.  Please let us know if you find any problems.



  • Cool, I was able to install NUT in 1.2.1-TESTING-SNAPSHOT-20080723-0316! Thanks for yet another job well done!! :D



  • When I install a new snapshot, the one package I have siproxd re installs and says its starting.

    When I go to the services page it says its stopped.  It does start manually however..

    :)



  • @chpalmer:

    When I install a new snapshot, the one package I have siproxd re installs and says its starting.

    When I go to the services page it says its stopped.  It does start manually however..

    I noticed the same "issue" with the reinstall of NUT after I used the Auto Update feature last night. It reinstalled fine, but it left the service stopped. Starting it manually worked fine just like for the above user!



  • starting ntop errors with  "Shared object librrd_th.so.2 not found" on a new install of 1.2.1 from today.



  • SquidGuard blacklist upload does not work. When I try to upload a new Shalla-Blacklist I get the following error:

    Fatal error: Allowed memory size of 12582912 bytes exhausted (tried to allocate 9123462 bytes) in /usr/local/pkg/squidguard_configurator.inc on line 1647



  • SquidGuard was just fixed.  Please reinstall.

    Iperf will be fixed on the next snapshot.

    in temrs of ntop, I would suggest doing this from a shell:

    rm -rf /var/db/pkg/*

    Diagnostics -> Backup/Restore -> Reinstall all packages



  • Bandwidthd failed to start for me on reboot.On next reboot it came up with machine.



  • Has the snort package been removed.  It no longer appears in the package manager.



  • @southman:

    Has the snort package been removed.  It no longer appears in the package manager.

    Yes, it is broken and needs someone to spend a good deal of time on it.



  • Scott, can you contact me offline and give me some more details regarding snort.

    Southman



  • Hi,

    IMSpector installs 0.5 of the package but still show 0.4 on the GUI.

    Lightsquid install (for the last couple of days now) but the Proxy Report is not working properly.
    Squid user access report
    Date: 27 Jul 2008 (update :: 07:00 :: 27 Jul 2008)

    Top Sites Report
    Big Files Report

    Time User Real Name Connect Bytes % Group

    1 [Graph Report] #000 ? 6 512 120.8 M 100.0% ?

    It only show #000.

    Otherwise fantastic progress!

    Regards,

    Darren



  • Hi,

    squidGuard does not work properly.  Squid install as 2.6.21 but when you install (delete and install, not reinstall) squidGuard it installs squid 2.6.20.

    Once it has overwritten 2.6.21 with 2.6.20 you get the aufs issue that you have to manually change to diskd for squid to start (squid -D) and squidGuard to work.

    squid -v

    Squid Cache: Version 2.6.STABLE20

    Prior to the delete install it showed

    squid -v | grep Version

    Squid Cache: Version 2.6.STABLE21

    I also experience the same problem with reloading blacklists.

    Regards,

    Darren



  • This must have to do with the fact that after having correctly installed squid .21 the following installer script of squidGuard will replace the newer squid with an older version.



  • I'm using snapshot 20080728 and I can't get ntop to start.  It seems to install fine, but the service won't start.



  • I'm using 1.2.1-RC1-20080730 and services ntop and darkstat won't start.
    I have tried to remove and reinstall the packages:
    rm -rf /var/db/pkg/*

    Diagnostics -> Backup/Restore -> Reinstall all packages

    It didn't help. ???



  • bandwidthd is broken.

    I installed from pfsense-20080723-0310.iso.gz last week then have just updated with pfSense-Full-Update-1.2.1-RC1-20080730-2326.tgz

    From eth GUI Services menu, BandwidthD -> Access BandwidthD displays

    Please start bandwidthd to populate this directory.

    If I try to start bandwidthd from a ssh session:

    /usr/local/bandwidthd/bandwidthd /usr/local/bandwidthd/etc/bandwidthd.conf

    /libexec/ld-elf.so.1: Shared object "libpq.so.5" not found, required by "bandwidthd"

    find / -name 'libpq*'



  • for ntop, it doesn't appear that the ntop.sh is being generated, there is only the standard package start script.
    Trying to start ntop from the command line it complains about not finding librrd_th.so.2  I can only find librrd.so.2 on the system.

    is the ntop package missing a dependency?  Or is the rrd implementation not complete in recent versions of pfsense?  I'm guessing the _th indicates ntop is looking for the threaded version of the library.



  • Hello!
    Where pkg_config.xml file for 1.2.1?



  • Name is changed to pkg_config.7.xml



  • @Perry:

    Name is changed to pkg_config.7.xml

    Thanks!!!
    –-
    about squid V 2.6.21
    I install in 1.2.1 and get errors woth config
    Must be in config line 20 'ufs' type cache (squid -v not contains 'aufs' support)
    cache_dir ufs /var/squid/cache




  • About squid and squidGuard problem's:

    squid

    FATAL: Bungled squid.conf line 20: cache_dir aufs /var/squid/cache 10 16 256
    Squid Cache (Version 2.6.STABLE20): Terminated abnormally.

    squid -v

    Squid Cache: Version 2.6.STABLE20
    configure options:
    … '--enable-storeio=ufs diskd null'  ...

    Need change squid.inc [1083]
    from:
    || $conf = <<<eod<br><< cache_dir aufs $cachedir $disk_cache_size $level1 256
    to:
    || $conf = <<<eod<br>>> cache_dir ufs $cachedir $disk_cache_size $level1 256</eod<br></eod<br>



  • @wallabybob:

    bandwidthd is broken.

    I installed from pfsense-20080723-0310.iso.gz last week then have just updated with pfSense-Full-Update-1.2.1-RC1-20080730-2326.tgz

    From eth GUI Services menu, BandwidthD -> Access BandwidthD displays

    Please start bandwidthd to populate this directory.

    If I try to start bandwidthd from a ssh session:

    /usr/local/bandwidthd/bandwidthd /usr/local/bandwidthd/etc/bandwidthd.conf

    /libexec/ld-elf.so.1: Shared object "libpq.so.5" not found, required by "bandwidthd"

    find / -name 'libpq*'

    I have a similar problem…

    When I ssh and try to start it manually I get

    /usr/local/bandwidthd/bandwidthd start

    /libexec/ld-elf.so.1: Shared object "libiconv.so.3" not found, required by "bandwidthd"

    cd /libexec/

    ls

    ld-elf.so.1

    So it looks like is missing it....



  • To make bandwidthd working copy libiconv.so.3 from any FreeBSD 7.0 install.
    Works for me…



  • I kind of figure that much but I dont have any FreeBSD installs…
    Can you email me or attach the lib here?

    TIA!



  • Thank You.
    I got the lib from a VMware instance.
    Who ever needs it please pm.

    Thank You.



  • squid 2.6.21 doesn't support 'aufs coss'':

    ./squid -v

    Squid Cache: Version 2.6.STABLE21
    configure options:  '–bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--datadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstatedir=/usr/local/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=lru heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll' '--enable-auth=basic digest negotiate ntlm' '--enable-basic-auth-helpers=DB NCSA PAM MSNT SMB YP' '--enable-digest-auth-helpers=password' '--enable-external-acl-helpers=ip_user session unix_group wbinfo_group' '--enable-ntlm-auth-helpers=SMB' '--enable-negotiate-auth-helpers=squid_kerb_auth' '–enable-storeio=ufs diskd null' '–enable-err-languages=Armenian Azerbaijani Bulgarian Catalan Czech Danish  Dutch English Estonian Finnish French German Greek  Hebrew Hungarian Italian Japanese Korean Lithuanian  Polish Portuguese Romanian Russian-1251 Russian-koi8-r  Serbian Simplify_Chinese Slovak Spanish Swedish  Traditional_Chinese Turkish Ukrainian-1251  Ukrainian-koi8-u Ukrainian-utf8' '--enable-default-err-language=English' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' 'i386-portbld-freebsd7.0' 'build_alias=i386-portbld-freebsd7.0' 'host_alias=i386-portbld-freebsd7.0' 'target_alias=i386-portbld-freebsd7.0' 'CC=cc' 'CFLAGS=-O2 -fno-strict-aliasing -pipe ' 'LDFLAGS=' 'CPPFLAGS='

    ./squid -v

    Squid Cache: Version 2.6.STABLE18
    configure options:  '–bindir=/usr/local/sbin' '--sbindir=/usr/local/sbin' '--datadir=/usr/local/etc/squid' '--libexecdir=/usr/local/libexec/squid' '--localstatedir=/usr/local/squid' '--sysconfdir=/usr/local/etc/squid' '--enable-removal-policies=lru heap' '--disable-linux-netfilter' '--disable-linux-tproxy' '--disable-epoll' '--enable-auth=basic ntlm digest' '--enable-basic-auth-helpers=DB NCSA PAM MSNT SMB LDAP YP' '--enable-digest-auth-helpers=password ldap' '--enable-external-acl-helpers=ip_user session unix_group wbinfo_group ldap_group' '--enable-ntlm-auth-helpers=SMB' '--enable-negotiate-auth-helpers=squid_kerb_auth' '--with-pthreads' '–enable-storeio=ufs diskd null aufs coss' '–enable-delay-pools' '--enable-snmp' '--enable-ssl' '--with-openssl=/usr' '--enable-icmp' '--disable-internal-dns' '--enable-htcp' '--enable-forw-via-db' '--enable-cache-digests' '--enable-wccpv2' '--enable-referer-log' '--enable-useragent-log' '--enable-arp-acl' '--enable-pf-transparent' '--enable-follow-x-forwarded-for' '--with-large-files' '--enable-large-cache-files' '--enable-err-languages=Armenian Azerbaijani Bulgarian Catalan Czech Danish  Dutch English Estonian Finnish French German Greek  Hebrew Hungarian Italian Japanese Korean Lithuanian  Polish Portuguese Romanian Russian-1251 Russian-koi8-r  Serbian Simplify_Chinese Slovak Spanish Swedish  Traditional_Chinese Turkish' '--enable-default-err-language=English' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' 'i386-portbld-freebsd6.2' 'build_alias=i386-portbld-freebsd6.2' 'host_alias=i386-portbld-freebsd6.2' 'target_alias=i386-portbld-freebsd6.2' 'CC=cc' 'CFLAGS=-O2 -fno-strict-aliasing -pipe  -I/usr/local/include  -I/usr/include' 'LDFLAGS= -L/usr/local/lib -rpath=/usr/lib:/usr/local/lib -L/usr/lib' 'CPPFLAGS='8

    Edit: –enable-delay-pools is also missing!





  • Squid (package 2.6.21) GUI:

    Proxy server: Cache management
    Memory replacement policy : any option selected here won't stick in config

    "The memory replacement policy determines which objects are purged from memory when space is needed. The default policy for memory replacement is GDSF."

    Other options not be saved in the /usr/local/etc/squid/squid.conf (stays heap GDSF)

    # Allow local network(s) on interface(s)
    acl localnet src  192.168.0.0/255.255.255.0
    uri_whitespace strip
    
    cache_dir aufs /var/squid/cache 1000 16 256
    cache_mem 128 MB
    maximum_object_size 16384 KB
    minimum_object_size 0 KB
    cache_replacement_policy heap LFUDA
    memory_replacement_policy heap GDSF <-----!!!!
    offline_mode off
    cache_swap_low 90
    cache_swap_high 95
    
    # No redirector configured
    

Log in to reply