RCC VE 2440 media not negotiating 1000baseT



  • Hello,
    I recently installed an RCC-VE 2440 with the pfSense-CE-memstick-ADI-2.3-RELEASE-amd64.img.gz image.  I noticed after install that I was negotiating only 100baseTX Full on the LAN port (the WAN port is currently disconnected).  I have several other devices connected to the same switch that negotiate 1000baseT full duplex.  I checked the forums but didn't see anyone with the same problem.  This leads me to believe I've either messed up the config somewhere or that there is some issue between the switch, Netgear GS108Tv2, and the RCC-VE 2440.

    I have seen various reports on the NIC hardware.  The netgate store pages says "4x RJ-45 1 GbE Intel Ethernet ports, Intel i350 (i354 on-die)" while the ADI engineering doc says "Two Ethernet ports are connected to the CPU through Intel i211 PCIe MAC/PHY IC's.  Four Ethernet ports are connected to the CPU's on-chip Gb MACs through a Marvell 88E1543 quad SGMII/PHY".  I note all that just to ask, do I need to get special drivers for the NICs or should they be included in the ADI image?

    Alas I did not note the speed of the port when running the included CentOS.  I enabled PowerD set to Hiadaptive.    Would greatly appreciate ideas about what to check next.



  • I just grabbed the following output from dmesg | grep igb1

    igb1: <intel(r) 1000="" pro="" network="" connection,="" version="" -="" 2.5.3-k="">port 0x1020-0x103f mem 0xdff80000-0xdff9ffff,0xdffe8000-0xdffebfff irq 19 at device 20.1 on pci0
    igb1: Using MSIX interrupts with 3 vectors
    igb1: Ethernet address: 00:08:a2:0a:5f:6e
    igb1: Bound queue 0 to cpu 0
    igb1: Bound queue 1 to cpu 1</intel(r)>



  • Try to force the port on the switch to 1000Mbps Full-Duplex then.

    Some switches don't act in Master mode on the port and the Intel NIC default to slave, they end up not being able to negotiate GbE speeds.



  • Don't force it, there's a reason it's not doing gigabit. That's essentially always a cable problem, using CAT-5 rather than CAT-5e or 6, or a bad cable.



  • Force it doesn't work because the GS108T doesn't allow you to set 1000baseT on the port.  It was relatively cheap and does 802.1x so I don't complain (much).

    A different cable!  I should have thought to try a different cable.  I just take cables so much for granted.  I will try that tonight and update with the results.  I have several other boxes doing 1000baseT so using a known good cable should let me eliminate that as a problem.



  • @cmb:

    Don't force it, there's a reason it's not doing gigabit. That's essentially always a cable problem, using CAT-5 rather than CAT-5e or 6, or a bad cable.

    Out of curiosity, since I've encountered the issue on certain Cisco equipment (ISR 891/ 1921).

    What's the issue if the link can't negotiate gigabit specifically only on pfSense?

    Installing Windows or Linux on the same machine with the same cables/ network ports negotiates GbE properly. As does using the same cable and port on another laptop/ computer.

    I've encountered similar issues on some cheap switches/ routers but I was able to set the negotiation on the NIC to Master mode (in Windows) that resolves the issue. Unfortunately, setting the same seems to require rebuilding the module in FreeBSD with the option set.



  • Confirmed, it was the cable.  BAH!  Always check layer 1 first.  Thank you


Log in to reply