DNS Resolver Overrides



  • I am trying to get this to work and I hope I can explain whats happening.

    I currently have a domain setup to forward subdomains to a certain address for example.

    http://movies.mydomain.com will forward to http://plex.mydomain.com:12345 (not my real port for security reasons)

    Then I have a DNS Resolver Override set as follows

    plex.mydomain.com = 192.168.1.xxx which is my LAN IP address.

    So when I go to movies.mydomain.com it works perfectly outside my local network. The WAN portion is handled beatuifully. I am able to access it because I have opened up the certain ports to allow the communication and can access the webgui for plex.

    However when I am on my local network and try to type in movies.mydomain.com it does not work properly. I can type in the movies.mydomain.com:12345 and it works perfectly on the local network but I want to simply type in movies.mydomain.com and have it forward like it does when I am not on my local network.

    Hopefully this makes sense and if you need any more details I will be glad to provide.


  • LAYER 8 Global Moderator

    Where does plex.mydomain.com resolve to 192.168.1.x ??  That sure and the hell would not work on the outside..

    If I am on the outside of your network and I go to movies.mydomain.com and there is a redirect that sends me to plex.mydomain.com and I resolved that to 192.168 how would I ever get there??

    what is the end goal here?  If you enabled your plex server remote access you can just go to the plex page and login and get access to your server.  if your on your own network and want to hit your plex server directly just go to the local url and port.  Not sure why people have problems with :portnumbers in a url  Would not only have to put this in once and then just hit it via your browser?  I have a bookmark that points to http://storage.local.lan:32400/web/index.html#  I personally don't like opening up anything to the pubic.  So when I am away and want to hit my plex I just vpn in and use that same above url.



  • Where does plex.mydomain.com resolve to 192.168.1.x ??  That sure and the hell would not work on the outside..

    Yes you are correct that would not work on the outside. Also plex.mydomain.com resolves to 192.168.1.xxx using the DNS Resolver override.

    I have also come to the conclusion that this wont work the way I was thinking. I pretty much confused myself this morning :P must be tired.

    If I am on the outside of your network and I go to movies.mydomain.com and there is a redirect that sends me to plex.mydomain.com and I resolved that to 192.168 how would I ever get there??

    This is done by my DNS on the domain. It allows me to forward plex.mydomain.com to http://externalip.mydomain.com:12345/index.html which is plex and works because I have the port open externally.

    what is the end goal here?  If you enabled your plex server remote access you can just go to the plex page and login and get access to your server.  if your on your own network and want to hit your plex server directly just go to the local url and port.  Not sure why people have problems with :portnumbers in a url  Would not only have to put this in once and then just hit it via your browser?  I have a bookmark that points to http://storage.local.lan:32400/web/index.html#  I personally don't like opening up anything to the pubic.  So when I am away and want to hit my plex I just vpn in and use that same above url.

    I just confused myself is all now that I think about it… its working the way you just described. When I access plex.mydomain.com locally it simply points to my plex ip address. I setup bookmarks to add the port number already... I was just thinking I could do something that made sense this morning lol.



  • Only thing I do recall is it was working both locally and externally when I would type movies.mydomain.com into a browser. It would auto redirect… now it seems my DNS entries are overriding the external DNS. Which is great for pinging / accessing that IP address but I think I have figured it out and know how I can get it to work.


Log in to reply