Router Advertisement Daemon



  • Hi,

    Since yesterday my ISP gave me access to IPV6
    I got everything working but I have 1 issue here
    every time PFSENSE reboots I have to manually restart the Router Advertisement Daemon otherwise my clients don't have IPV6 access
    could this be a bug or I am missing something ?
    I'm running the latest version of pfsense 2.3.1 , I use stateless config , with dhcp6 enabled same issue occurs

    thx



  • Are you merely restarting the router advertisement daemon? I have a similar issue but I must do something else to get IPv6 working again for the LAN.

    If I halt pfSense, power cycle my modem and restart pfSense, the router advertisements pfSense sends don't include a default route. pfSense itself has full IPv6 connectivity but restarting radvd doesn't fix the advertisements. I have to go to interfaces->WAN and click save, then apply to get IPv6 for the LAN again.

    In my logs under system->routing, I see this:

    no auto-selected prefix on interface re1, disabling advertisements
    

    I did the (pfSense halt, modem power cycle, pfSense poweron) multiple times and this happened each time. Seems like a new issue with 2.3.1?



  • I run pfsense as a vm on my esxi6 server
    when I live migrate the nic for the lan to another nic then it works instantly
    after reboot same issue
    when I then migrate the lan nic to the original nic then it works also …until I reboot
    very strange

    your workaround works also for me



  • I have found the solution!

    instead of configuring the lan interface to 'track interface'  ,  I used a static ipv6 address and now it works
    also those messages in the log are gone now


Log in to reply