Very difficult to configure Unbound when WAN connection is down (new install)



  • Today I was setting up a new router from scratch at a site that did not yet have internet access active.  The modem was there but the service wasn't scheduled to turn on for another couple of hours.  I thought I could get a head start by flashing the pfSense router, setting up the interfaces, configuring various settings, DHCP static leases, Unbound, etc.

    Turns out configuring the unit without having internet access is very painful.  Pages hang or do not seem to save properly (including Dashboard, DNS Resolver, General Setup, and probably others. Out of these- DNS Resolver (unbound) was the most troublesome.  I literally could not get the page to save until we had internet access. I would hit the Save button, and the wheel would spin for a while and then the page would eventually time out. Upon refresh the page would reload but my settings had been lost.

    Is there anything that can be done differently to avoid these hangs? Or is this something that has to wait until PHP is replaced in 3.0 (is that still the plan?)

    Thanks and sorry to complain … I truly love pfSense and am very thankful for all of the amazing work that has gone into 2.3!!



  • +1 for making pfSense more reliable to be used offline.



  • I noticed that when the dashboard firmware Update Check is working (gear spinning) that often times this will hang PHP and so clicking anywhere else in the webGUI will not respond until whatever process or thread is doing that update completes or times out.  For now I have disabled the update check on dashboard.  Not sure what is going on there or how to fix it unfortunately.  :(



  • @luckman212:

    I noticed that when the dashboard firmware Update Check is working (gear spinning) that often times this will hang PHP and so clicking anywhere else in the webGUI will not respond until whatever process or thread is doing that update completes or times out.  For now I have disabled the update check on dashboard.  Not sure what is going on there or how to fix it unfortunately.  :(

    If the system does not have internet access to find the various repos to check with, then there are going to be a lot of delays for timeouts as attempts are made at the checks. For that case you really do want to disable the update check, as you did.



  • The thing is, I am seeing the long delays even when the router does have a working WAN connection.  If you log on to a fresh system, with the dashboard update check enabled, and while the gear is spinning try to navigate to another page, you will probably see it.  Delay of up to ~10 seconds. As soon as the check finishes, the navigation to the next page continues.


Log in to reply