Port not being correctly forwarded, causing timeout issues.



  • Hey all. I have a funambol server running on my private network that i need to expose to the internet.  I have changed the port the server runs on to 8182, and i thought i did everything i needed to do to make the flowing work:

    Http://<public ip="">:8081/  should translate into Http://<internal ip="">:8182/

    i have tested this from my own internal network and externally, either way i get a time out error.

    if the ports are being correctly forwarded, what is causing the timeout?

    edit:  how do i subscribe to a thread?!?  i cant find a way to do so!</internal></public>



  • You haven't mentioned the steps you took towards creating your port forward rules (or what version of pfsense you are using).  I would delete the two respective rules that you have (which were created when you created your port forwards rules).  There should be one listed under NAT and another under RULES:WAN.  Once deleted, follow these steps:

    Go to NAT, and create a new port-forward rule:

    Leave the Interface, External address and Protocol options alone if they are all good.

    For external port, enter in: 8081
    for NAT IP, enter in: INTERNAL IP of SERVER
    for Local Port, enter in: 8182

    Make sure that the "Auto-add a firewall rule" checkbox is checked and click on SAVE.  Then hit APPLY to have your settings changed.

    With your listed setup, someone on the Internet would be connecting to port 8081 of your WAN ip address, and pfsense would be forwarding the request to port 8182 on your internal server.

    Good luck!

    ps (Just wondering, but why are you changing the default port of your internal server? Do you have something else on that machines that uses port 8081 as well?)



  • I am changing the port for security reasons.  There was nothing else running on that port, but I can add a tiny bit of security by changing the default port.

    I created the port forward rule via the wizard and I believe that I followed the exact steps you have outlined above.  I do know that after the first failed attempt, I followed the guide on the Wiki to the letter.
    I am away from my home network (and don’t have the resources to establish a VPN connection) so I cannot tell you what steps I took right now.

    When I get access to my home network, I will go through the steps above and I will post back with my results.

    PS:  the server runs on 8182, not 8081

    PPS:  Sorry it took me forever to respond.  I have been VERY busy this last week with school + personal stuff.



  • Nope.  followed your instructions to the letter.  I still get time out errors.

    – i have found a temporary work around that does not require me to access my Funambol server from outside my personal letwork.

    thanks for the help.



  • If you need to do so in the future, follow the steps here.
    http://doc.pfsense.org/index.php/Port_Forward_Troubleshooting


Log in to reply