2.3 Boots to mountroot and then stops



  • Hi all,
    Apologies if this has been covered, I did a few searches and tried every available avenue I found, but none of them seemed to work.
    A bit of context - I picked up a couple of older (~2010) hardware firewalls on ebay, as I'm looking for 3-4 cheap ones so I can standardize the hardware in my house, and my parents/inlaws.
    These boxes are a Celeron M 1.5/1Gb ram and 4x1Gbit intel network cards. x86 only…
    I can install from the pfsense serial image just fine (although during install, the hard disk controller has to be in compatibility mode, else after install I get a can't find /boot/kernel/kernel error. After the install, I can notch the drive back to AHCI, but then I get the same error I'm about to describe).
    The boot runs fine up to the bit where it looks at the drive, at which point I see:

    
    ada0 at ata0 bus 0 scbus0 target 0 lun 0
    ada0: <hitachi hte543232a7a384="" es2oa70b="">ATA8-ACS SATA 2.x device
    ada0: Serial Number E20342BL1XGNHP
    ada0: 150.000MB/s transfers (SATA, UDMA5, PIO 8192bytes)
    ada0: 305245MB (625142448 512 byte sectors)
    ada0: Previously was known as ad0
    
    Loader variables:
    
    Manual root filesystem specification:
      <fstype>: <device>[options]
          Mount <device>using filesystem <fstype>and with the specified (optional) option list.
    
        eg. ufs:/dev/da0s1a
            zfs:tank
            cd9660:/dev/acd0 ro
              (which is equivalent to: mount -t cd9660 -o ro /dev/acd0 /)
    
      ?               List valid disk boot devices
      .               Yield 1 second (for background tasks)
      <empty line="">Abort manual input
    
    mountroot></empty></fstype></device></device></fstype></hitachi> 
    

    If I type:

    ufs:/dev/ada0s1a

    And press enter, the system boots just fine and works without issue.
    I trolled around on the pfsense boards and have tried the various fixes suggested (playing with the IDE mode on the controller/installing with/without packet mode, embedded vs vga console)
    I've tried the following additons to /boot/loader.conf (and loader.conf.local)

    • autoboot_delay="3"

    • ahci_load="YES"

    • kern.cam.boot_delay=10000

    • vfs.root.mounttrymax=10

    And those don't appear to help individually or in combination.
    I've also tried updating /etc/fstab to reference the drive directly:

    /dev/ada0s1a / ufs rw 1 1

    And that doesn't seem to hold either…
    Is there something really obvious I've missed? Unfortunately I don't believe there are BIOS updates for the board, although I'm still exploring that avenue...it just seems odd that I can enter the filesystem and drive path and it works absolutely fine to the next reboot.

    Any help gladly received (/would even be willing to offer a paypal bounty, as the next step is buying a set of WatchGuard XTM 5's...)

    Thanks for your time!



  • Found a workaround overnight.
    Looks like I can add:

    
    vfs.root.mountfrom="ufs:/dev/ada0s1a"
    
    

    To my /boot/loader.conf file and it'll now start after every reboot without additional input from me.

    To those in the know, do I also need to add this command to /boot/loader.conf.local as I'm sure I read somewhere that the loader.conf file can get wiped out by updates, wheras the .local one doesn't?

    Thanks!


Log in to reply