Some issues found



  • Hi,

    Installed pfSense-20080723-1711.iso fresh on my C2D based ITX machine. Works as expected like a charm.
    Then tried to upgrade something newer build not just latest.tgz but other iso's built after 20080723-1711
    then found;

    1. ISO images after pfSense-20080723-1711, has some script issues when booting. I just tried out the following;
        20080725-1641.iso
        20080726-1844.iso
        20080726-2143.iso
        20080727-0608.iso
        20080727-0907.iso
    all those images have the same issue which wouldn't allow me to configure anything. The error messages basically
    telling me that something is missing in *.inc (just too much to remember). This is easy to replicate, just burn any
    newer build and boot it off to see what happen.

    2. Upgdate using not just _updaters/latest.tgz but other full update .tgz also caused my PPTP client on Vista to the
    outside server stopped working. Newer build would not passthru GRE(well would not pass return traffic from the server).
    I've added to permit any/any from ther server, no success. I also compared every single char/line between previous and
    updated filters by using pfctl -sr but both are exactly the same but the client stacked at right after authentication
    ("Checking ID/PASSWORD" message).

    Both two issues force me to stay at 20080723-1711 build but other than that 1.3-A-A has already reached some sort of
    quality, IMHO.



  • I had the same problem, no one of the latest ISOs are usable, many errors while booting:

    warning:Invalid argument supplied for foreach() in etc/inc/util.inc line 28
    .
    .
    warning:Invalid argument supplied for foreach() in etc/inc/util.inc line 30

    Then when I try to set any interface  get a similar error:

    warning:Invalid argument supplied for foreach() in etc/inc/util.inc line 28

    And is not possible to setup anything.

    Then I installed a 1.2 version and upgrade to latest 1.3 Alpha, now is working with version:

    1.3-ALPHA-ALPHA
    built on Mon Jul 28 23:45:47 EDT 2008
    FreeBSD 7.0-RELEASE-p3



  • When try to see Services Status I get the following error:

    Status: Services

    Fatal error: Cannot use string offset as an array in /usr/local/www/status_services.php on line 267



  • A recent 1.3 commit caused some problems, try again in a couple days.



  • Hello,

    It's good to hear from one of senior members, means that the "TEAM" aware of the issues.

    I will give it a try with later build in the weekend.



  • this has been fixed


Log in to reply