My squid fails to delete or load with pics



  • My squid install is fouling up my opti net , the squid fails to uninstall or reinstall  what can be done  ?

    Installing pfSense-pkg-squidGuard…
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking integrity... done (0 conflicting)
    The following 7 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    pfSense-pkg-squidGuard: 1.14_3 [pfSense]
    squidGuard: 1.4_15 [pfSense]
    db5: 5.3.28_3 [pfSense]
    squid: 3.5.19 [pfSense]
    krb5: 1.14.1 [pfSense]
    pkgconf: 0.9.12_1 [pfSense]
    cyrus-sasl: 2.1.26_12 [pfSense]

    The process will require 29 MiB more space.
    [1/7] Installing pkgconf-0.9.12_1…
    [1/7] Extracting pkgconf-0.9.12_1: ….... done
    [2/7] Installing krb5-1.14.1…
    [2/7] Extracting krb5-1.14.1: …....... done
    [3/7] Installing cyrus-sasl-2.1.26_12…
    *** Updated user `cyrus'.
    [3/7] Extracting cyrus-sasl-2.1.26_12: …....... done
    [4/7] Installing db5-5.3.28_3…
    [4/7] Extracting db5-5.3.28_3: …....... done
    [5/7] Installing squid-3.5.19…
    ===> Creating users and/or groups.
    Using existing group 'squid'.
    Using existing user 'squid'.
    ===> Pre-installation configuration for squid-3.5.19
    [5/7] Extracting squid-3.5.19: …......
    pkg: cannot rename //usr/local/etc/squid/errors/zh-cn.NyXZdUVRExqV to //usr/local/etc/squid/errors/zh-cn: Is a directory
    [5/7] Extracting squid-3.5.19… done
    [5/7] Deleting files for squid-3.5.19: …....... done
    Failed

    many thanks o handsome gurus of  pfsense......


  • Rebel Alliance

    Login via ssh and

    rm -fr /usr/local/etc/squid/errors/zh-cn

    Then try again.



  • tried that comes back with  error message  that  squid guard is only partially deleted,
    it shows up in the packages section with a red exclamation mark and does not run.

    likewise it appears in the list of packages but you cannot run or delete it ?

    with the red exclamation mark

    pics of the trouble makers

    Wont run

    will not delete … will not reload

    Thanks


Log in to reply